math/mpfi - The NetBSD Packages Collection

Multiprecision interval arithmetic library

MPFI (Multiple Precision Floating-Point Interval Library) is a library
for arbitrary precision interval arithmetic with intervals represented
using MPFR reliable floating-point numbers. It is based on the GNU MP
library and on the MPFR library. The purpose of an arbitrary precision
interval arithmetic is on the one hand to get guaranteed results,
thanks to interval computation, and on the other hand to obtain
accurate results, thanks to multiple precision arithmetic. The MPFI
library is built upon MPFR to benefit from the correct roundings
provided by MPFR, it portability, and its compliance with the IEEE 754
standard for floating-point arithmetic.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf

Runtime dependencies

math/mpfr math/mpfr

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmpfi-1.5.4.tgz
NetBSD 8.0earmv7hfmpfi-1.5.4.tgz
NetBSD 8.0earmv7hfmpfi-1.5.4.tgz
NetBSD 8.0i386mpfi-1.5.4.tgz
NetBSD 8.0i386mpfi-1.5.4.tgz
NetBSD 8.0powerpcmpfi-1.5.4.tgz
NetBSD 8.0powerpcmpfi-1.5.4.tgz
NetBSD 8.0powerpcmpfi-1.5.4.tgz
NetBSD 8.0powerpcmpfi-1.5.4.tgz
NetBSD 8.0x86_64mpfi-1.5.4.tgz
NetBSD 8.0x86_64mpfi-1.5.4.tgz
NetBSD 9.0aarch64mpfi-1.5.4.tgz
NetBSD 9.0aarch64mpfi-1.5.4.tgz
NetBSD 9.0aarch64mpfi-1.5.4.tgz
NetBSD 9.0alphampfi-1.5.4.tgz
NetBSD 9.0alphampfi-1.5.4.tgz
NetBSD 9.0alphampfi-1.5.4.tgz
NetBSD 9.0earmmpfi-1.5.4.tgz
NetBSD 9.0earmmpfi-1.5.4.tgz
NetBSD 9.0earmmpfi-1.5.4.tgz
NetBSD 9.0earmv6hfmpfi-1.5.4.tgz
NetBSD 9.0earmv6hfmpfi-1.5.4.tgz
NetBSD 9.0earmv6hfmpfi-1.5.4.tgz
NetBSD 9.0earmv7hfmpfi-1.5.4.tgz
NetBSD 9.0earmv7hfmpfi-1.5.4.tgz
NetBSD 9.0earmv7hfmpfi-1.5.4.tgz
NetBSD 9.0earmv7hfmpfi-1.5.4.tgz
NetBSD 9.0i386mpfi-1.5.4.tgz
NetBSD 9.0i386mpfi-1.5.4.tgz
NetBSD 9.0mips64ebmpfi-1.5.4.tgz
NetBSD 9.0mips64ebmpfi-1.5.4.tgz
NetBSD 9.0mips64ebmpfi-1.5.4.tgz
NetBSD 9.0mips64ebmpfi-1.5.4.tgz
NetBSD 9.0mips64ebmpfi-1.5.4.tgz
NetBSD 9.0powerpcmpfi-1.5.4.tgz
NetBSD 9.0powerpcmpfi-1.5.4.tgz
NetBSD 9.0powerpcmpfi-1.5.4.tgz
NetBSD 9.0powerpcmpfi-1.5.4.tgz
NetBSD 9.0sh3elmpfi-1.5.4.tgz
NetBSD 9.0sh3elmpfi-1.5.4.tgz
NetBSD 9.0sh3elmpfi-1.5.4.tgz
NetBSD 9.0sparc64mpfi-1.5.4.tgz
NetBSD 9.0sparc64mpfi-1.5.4.tgz
NetBSD 9.0sparc64mpfi-1.5.4.tgz
NetBSD 9.0sparcmpfi-1.5.4.tgz
NetBSD 9.0sparcmpfi-1.5.4.tgz
NetBSD 9.0sparcmpfi-1.5.4.tgz
NetBSD 9.0sparcmpfi-1.5.4.tgz
NetBSD 9.0x86_64mpfi-1.5.4.tgz
NetBSD 9.0x86_64mpfi-1.5.4.tgz
NetBSD 9.0x86_64mpfi-1.5.4.tgz
NetBSD 9.0x86_64mpfi-1.5.4.tgz
NetBSD 9.0x86_64mpfi-1.5.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.