math/mpfr - The NetBSD Packages Collection

GMP-based library for multiple-precision floating-point computations

The MPFR library is a C library for multiple-precision floating-point
computations with exact rounding (also called correct rounding).  It is
based on the GMP multiple-precision library and should replace the MPF
class in further releases of GMP.

  The main goal of MPFR is to provide a library for multiple-precision
floating-point computation which is both efficient and has a well-defined
semantics.  It copies the good ideas from the ANSI/IEEE-754 standard for
double-precision floating-point arithmetic (53-bit mantissa).

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

devel/gmp devel/gmp devel/gmp

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmpfr-4.1.0.tgz
NetBSD 8.0earmv7hfmpfr-4.1.0.tgz
NetBSD 8.0earmv7hfmpfr-4.1.0.tgz
NetBSD 8.0i386mpfr-4.1.0.tgz
NetBSD 8.0i386mpfr-4.1.0.tgz
NetBSD 8.0powerpcmpfr-4.1.0.tgz
NetBSD 8.0powerpcmpfr-4.1.0.tgz
NetBSD 8.0powerpcmpfr-4.1.0.tgz
NetBSD 8.0powerpcmpfr-4.1.0.tgz
NetBSD 8.0x86_64mpfr-4.1.0.tgz
NetBSD 8.0x86_64mpfr-4.1.0.tgz
NetBSD 9.0aarch64mpfr-4.1.0.tgz
NetBSD 9.0aarch64mpfr-4.1.0.tgz
NetBSD 9.0aarch64mpfr-4.1.0.tgz
NetBSD 9.0alphampfr-4.1.0.tgz
NetBSD 9.0alphampfr-4.1.0.tgz
NetBSD 9.0alphampfr-4.1.0.tgz
NetBSD 9.0earmmpfr-4.1.0.tgz
NetBSD 9.0earmmpfr-4.1.0.tgz
NetBSD 9.0earmmpfr-4.1.0.tgz
NetBSD 9.0earmv6hfmpfr-4.1.0.tgz
NetBSD 9.0earmv6hfmpfr-4.1.0.tgz
NetBSD 9.0earmv6hfmpfr-4.1.0.tgz
NetBSD 9.0earmv7hfmpfr-4.1.0.tgz
NetBSD 9.0earmv7hfmpfr-4.1.0.tgz
NetBSD 9.0earmv7hfmpfr-4.1.0.tgz
NetBSD 9.0earmv7hfmpfr-4.1.0.tgz
NetBSD 9.0i386mpfr-4.1.0.tgz
NetBSD 9.0i386mpfr-4.1.0.tgz
NetBSD 9.0i386mpfr-4.1.0.tgz
NetBSD 9.0m68kmpfr-4.1.0.tgz
NetBSD 9.0m68kmpfr-4.1.0.tgz
NetBSD 9.0m68kmpfr-4.1.0.tgz
NetBSD 9.0m68kmpfr-4.1.0.tgz
NetBSD 9.0mips64ebmpfr-4.1.0.tgz
NetBSD 9.0mips64ebmpfr-4.1.0.tgz
NetBSD 9.0mips64ebmpfr-4.1.0.tgz
NetBSD 9.0mips64ebmpfr-4.1.0.tgz
NetBSD 9.0mips64ebmpfr-4.1.0.tgz
NetBSD 9.0mipselmpfr-4.1.0.tgz
NetBSD 9.0mipselmpfr-4.1.0.tgz
NetBSD 9.0mipselmpfr-4.1.0.tgz
NetBSD 9.0mipselmpfr-4.1.0.tgz
NetBSD 9.0powerpcmpfr-4.1.0.tgz
NetBSD 9.0powerpcmpfr-4.1.0.tgz
NetBSD 9.0powerpcmpfr-4.1.0.tgz
NetBSD 9.0powerpcmpfr-4.1.0.tgz
NetBSD 9.0sh3elmpfr-4.1.0.tgz
NetBSD 9.0sh3elmpfr-4.1.0.tgz
NetBSD 9.0sh3elmpfr-4.1.0.tgz
NetBSD 9.0sh3elmpfr-4.1.0.tgz
NetBSD 9.0sh3elmpfr-4.1.0.tgz
NetBSD 9.0sparc64mpfr-4.1.0.tgz
NetBSD 9.0sparc64mpfr-4.1.0.tgz
NetBSD 9.0sparc64mpfr-4.1.0.tgz
NetBSD 9.0sparcmpfr-4.1.0.tgz
NetBSD 9.0sparcmpfr-4.1.0.tgz
NetBSD 9.0sparcmpfr-4.1.0.tgz
NetBSD 9.0sparcmpfr-4.1.0.tgz
NetBSD 9.0sparcmpfr-4.1.0.tgz
NetBSD 9.0vaxmpfr-4.1.0.tgz
NetBSD 9.0vaxmpfr-4.1.0.tgz
NetBSD 9.0vaxmpfr-4.1.0.tgz
NetBSD 9.0vaxmpfr-4.1.0.tgz
NetBSD 9.0x86_64mpfr-4.1.0.tgz
NetBSD 9.0x86_64mpfr-4.1.0.tgz
NetBSD 9.0x86_64mpfr-4.1.0.tgz
NetBSD 9.0x86_64mpfr-4.1.0.tgz
NetBSD 9.0x86_64mpfr-4.1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.