devel/ocaml-ppx_jane - The NetBSD Packages Collection

Standard Jane Street PPX rewriters for OCaml

ppx_jane is a ppx_driver including all standard Jane Street ppx rewriters.

Build dependencies

misc/ocaml-opaline misc/ocaml-opaline pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/ocaml-base_quickcheck devel/ocaml-ppx_assert devel/ocaml-ppx_base devel/ocaml-ppx_bench devel/ocaml-ppx_bin_prot devel/ocaml-ppx_custom_printf devel/ocaml-ppx_disable_unused_warnings devel/ocaml-ppx_expect devel/ocaml-ppx_fail devel/ocaml-ppx_fields_conv devel/ocaml-ppx_fixed_literal devel/ocaml-ppx_here devel/ocaml-ppx_ignore_instrumentation devel/ocaml-ppxlib devel/ocaml-ppx_inline_test devel/ocaml-ppx_let devel/ocaml-ppx_log devel/ocaml-ppx_module_timer devel/ocaml-ppx_optcomp devel/ocaml-ppx_optional devel/ocaml-ppx_pipebang devel/ocaml-ppx_sexp_message devel/ocaml-ppx_sexp_value devel/ocaml-ppx_stable devel/ocaml-ppx_string devel/ocaml-ppx_typerep_conv devel/ocaml-ppx_variants_conv devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-base_quickcheck devel/ocaml-ppx_assert devel/ocaml-ppx_base devel/ocaml-ppx_bench devel/ocaml-ppx_bin_prot devel/ocaml-ppx_custom_printf devel/ocaml-ppx_expect devel/ocaml-ppx_fail devel/ocaml-ppx_fields_conv devel/ocaml-ppx_here devel/ocaml-ppxlib devel/ocaml-ppx_inline_test devel/ocaml-ppx_let devel/ocaml-ppx_module_timer devel/ocaml-ppx_optcomp devel/ocaml-ppx_optional devel/ocaml-ppx_pipebang devel/ocaml-ppx_sexp_message devel/ocaml-ppx_sexp_value devel/ocaml-ppx_stable devel/ocaml-ppx_typerep_conv devel/ocaml-ppx_variants_conv devel/ocaml-dune devel/ocaml-findlib

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0earmv6hfocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0earmv6hfocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0earmv7hfocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0earmv7hfocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0powerpcocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0powerpcocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 10.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0powerpcocaml-ppx_jane-0.13.0nb1.tgz
NetBSD 8.0powerpcocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0powerpcocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 8.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0aarch64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0aarch64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0aarch64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0earmv6hfocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0earmv6hfocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0earmv7hfocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0earmv7hfocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0i386ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0x86_64ocaml-ppx_jane-0.15.0.tgz
NetBSD 9.0x86_64ocaml-ppx_jane-0.15.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.