devel/ocaml-ppx_expect - The NetBSD Packages Collection

Cram-like framework for OCaml

Expect-test is a framework for writing tests in OCaml, similar to Cram.
Expect-tests mimic the existing inline tests framework. The body of an
expect-test can contain output-generating code, interleaved with %expect
extension expressions to denote the expected output.

Build dependencies

misc/ocaml-opaline pkgtools/cwrappers misc/ocaml-opaline

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-base devel/ocaml-ppx_assert devel/ocaml-ppx_compare devel/ocaml-ppx_custom_printf devel/ocaml-ppx_fields_conv devel/ocaml-ppx_here devel/ocaml-ppx_inline_test devel/ocaml-ppx_sexp_conv devel/ocaml-ppx_variants_conv devel/ocaml-ppxlib devel/ocaml-re devel/ocaml-stdio devel/ocaml-dune devel/ocaml-findlib devel/ocaml-base devel/ocaml-ppx_assert devel/ocaml-ppx_compare devel/ocaml-ppx_custom_printf devel/ocaml-ppx_fields_conv devel/ocaml-ppx_here devel/ocaml-ppx_inline_test devel/ocaml-ppx_sexp_conv devel/ocaml-ppx_variants_conv devel/ocaml-ppxlib devel/ocaml-re devel/ocaml-stdio

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0i386ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 8.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0aarch64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0aarch64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0aarch64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv6hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv6hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv6hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv7hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv7hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv7hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0earmv7hfocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0i386ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0i386ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0i386ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0powerpcocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz
NetBSD 9.0x86_64ocaml-ppx_expect-0.13.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.