x11/xpad - The NetBSD Packages Collection

Sticky notes application for GTK+ 2.0

xpad is a sticky notes application written using GTK+ 2.0 that strives to
be simple, fault-tolerant, and customizable. xpad consists of independent
pad windows; each is basically a text box in which notes can be written.
Despite being called xpad, all that is needed to run or compile it is the
GTK+ 2.0 libraries. Here is a list of major features in the current xpad
stable release:

 * GTK+ 2.0 powered text view.
 * Fault tolerant. All information is kept on the hard drive, not memory.
   So if power is lost or your computer freezes, there is little lost
   information.
 * xpad is very customizable. The color scheme (text, background, and window
   borders) and the font can be changed. These settings can be applied to
   one pad or set as the default for future pads. Want window decorations or
   not? Your choice.
 * A customizable toolbar puts the most frequently used commands at your
   fingertips.
 * Support for the X session management protocol.
 * Support for the www.freedesktop.org system tray proposal.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto x11/xcb-proto devel/glib2-tools pkgtools/mktools textproc/intltool devel/gmake lang/perl5 devel/pkgconf pkgtools/cwrappers

Runtime dependencies

graphics/hicolor-icon-theme x11/gtk3 x11/gtksourceview3 graphics/hicolor-icon-theme x11/gtk3 x11/gtksourceview3

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64xpad-4.8.0nb26.tgz
NetBSD 10.0aarch64xpad-4.8.0nb26.tgz
NetBSD 10.0aarch64ebxpad-4.8.0nb26.tgz
NetBSD 10.0alphaxpad-4.8.0nb26.tgz
NetBSD 10.0alphaxpad-4.8.0nb26.tgz
NetBSD 10.0earmv6hfxpad-4.8.0nb26.tgz
NetBSD 10.0earmv6hfxpad-4.8.0nb26.tgz
NetBSD 10.0earmv7hfxpad-4.8.0nb26.tgz
NetBSD 10.0earmv7hfxpad-4.8.0nb26.tgz
NetBSD 10.0i386xpad-4.8.0nb26.tgz
NetBSD 10.0i386xpad-4.8.0nb26.tgz
NetBSD 10.0powerpcxpad-4.8.0nb22.tgz
NetBSD 10.0powerpcxpad-4.8.0nb26.tgz
NetBSD 10.0sparcxpad-4.8.0nb26.tgz
NetBSD 10.0x86_64xpad-4.8.0nb26.tgz
NetBSD 10.0x86_64xpad-4.8.0nb26.tgz
NetBSD 9.0aarch64xpad-4.8.0nb26.tgz
NetBSD 9.0aarch64xpad-4.8.0nb26.tgz
NetBSD 9.0earmxpad-4.8.0nb21.tgz
NetBSD 9.0earmv7hfxpad-4.8.0nb26.tgz
NetBSD 9.0earmv7hfxpad-4.8.0nb26.tgz
NetBSD 9.0i386xpad-4.8.0nb26.tgz
NetBSD 9.0i386xpad-4.8.0nb26.tgz
NetBSD 9.0mips64ebxpad-4.8.0nb21.tgz
NetBSD 9.0powerpcxpad-4.8.0nb26.tgz
NetBSD 9.0powerpcxpad-4.8.0nb22.tgz
NetBSD 9.0powerpcxpad-4.8.0nb26.tgz
NetBSD 9.0sparc64xpad-4.8.0nb21.tgz
NetBSD 9.0x86_64xpad-4.8.0nb26.tgz
NetBSD 9.0x86_64xpad-4.8.0nb26.tgz
NetBSD 9.3x86_64xpad-4.8.0nb29.tgz
NetBSD 9.3x86_64xpad-4.8.0nb29.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.