www/wwwoffle - The NetBSD Packages Collection

WWW proxy with support for offline browsing

The wwwoffled program is a simple proxy server with special features for use
with dial-up internet links.  This means that it is possible to browse web
pages and read them without having to remain connected.

The cache created by wwwoffled is searchable with the addition of the
ht://Dig program.  Consider using the www/htdig package.

Build dependencies

pkgtools/cwrappers devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

security/gnutls security/libgcrypt security/gnutls security/gnutls security/libgcrypt

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfwwwoffle-2.9jnb10.tgz
NetBSD 8.0earmv7hfwwwoffle-2.9jnb8.tgz
NetBSD 8.0earmv7hfwwwoffle-2.9jnb10.tgz
NetBSD 8.0i386wwwoffle-2.9jnb8.tgz
NetBSD 8.0i386wwwoffle-2.9jnb10.tgz
NetBSD 8.0powerpcwwwoffle-2.9jnb8.tgz
NetBSD 8.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 8.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 8.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 8.0x86_64wwwoffle-2.9jnb8.tgz
NetBSD 8.0x86_64wwwoffle-2.9jnb10.tgz
NetBSD 9.0aarch64wwwoffle-2.9jnb10.tgz
NetBSD 9.0aarch64wwwoffle-2.9jnb8.tgz
NetBSD 9.0aarch64wwwoffle-2.9jnb10.tgz
NetBSD 9.0alphawwwoffle-2.9jnb10.tgz
NetBSD 9.0alphawwwoffle-2.9jnb8.tgz
NetBSD 9.0alphawwwoffle-2.9jnb10.tgz
NetBSD 9.0earmwwwoffle-2.9jnb8.tgz
NetBSD 9.0earmwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmv6hfwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmv6hfwwwoffle-2.9jnb8.tgz
NetBSD 9.0earmv6hfwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmv7hfwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmv7hfwwwoffle-2.9jnb8.tgz
NetBSD 9.0earmv7hfwwwoffle-2.9jnb10.tgz
NetBSD 9.0earmv7hfwwwoffle-2.9jnb10.tgz
NetBSD 9.0i386wwwoffle-2.9jnb8.tgz
NetBSD 9.0i386wwwoffle-2.9jnb10.tgz
NetBSD 9.0i386wwwoffle-2.9jnb10.tgz
NetBSD 9.0mips64ebwwwoffle-2.9jnb10.tgz
NetBSD 9.0mips64ebwwwoffle-2.9jnb8.tgz
NetBSD 9.0mips64ebwwwoffle-2.9jnb8.tgz
NetBSD 9.0mips64ebwwwoffle-2.9jnb8.tgz
NetBSD 9.0mips64ebwwwoffle-2.9jnb10.tgz
NetBSD 9.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 9.0powerpcwwwoffle-2.9jnb8.tgz
NetBSD 9.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 9.0powerpcwwwoffle-2.9jnb10.tgz
NetBSD 9.0sh3elwwwoffle-2.9jnb10.tgz
NetBSD 9.0sh3elwwwoffle-2.9jnb8.tgz
NetBSD 9.0sh3elwwwoffle-2.9jnb10.tgz
NetBSD 9.0sparc64wwwoffle-2.9jnb10.tgz
NetBSD 9.0sparc64wwwoffle-2.9jnb8.tgz
NetBSD 9.0sparc64wwwoffle-2.9jnb10.tgz
NetBSD 9.0sparcwwwoffle-2.9jnb10.tgz
NetBSD 9.0sparcwwwoffle-2.9jnb8.tgz
NetBSD 9.0sparcwwwoffle-2.9jnb8.tgz
NetBSD 9.0sparcwwwoffle-2.9jnb8.tgz
NetBSD 9.0sparcwwwoffle-2.9jnb10.tgz
NetBSD 9.0x86_64wwwoffle-2.9jnb10.tgz
NetBSD 9.0x86_64wwwoffle-2.9jnb10.tgz
NetBSD 9.0x86_64wwwoffle-2.9jnb8.tgz
NetBSD 9.0x86_64wwwoffle-2.9jnb10.tgz
NetBSD 9.0x86_64wwwoffle-2.9jnb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnutls
Enable GNU TLS support.
inet6
Enable support for IPv6.
libgcrypt
Use GNU cryptographic library.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.