www/tinyproxy - The NetBSD Packages Collection

Lightweight HTTP/SSL proxy

tinyproxy is a lightweight HTTP/SSL proxy. Designed from the ground up to be
fast and yet small, it is an ideal solution for sites where a full-featured
HTTP proxy is required, but the system resources required to run a more
demanding HTTP proxy are unavailable. tinyproxy is fully compatible with all
existing web browsers.

Build dependencies

textproc/asciidoc devel/gperf pkgtools/cwrappers devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftinyproxy-1.11.0.tgz
NetBSD 8.0earmv7hftinyproxy-1.10.0nb2.tgz
NetBSD 8.0earmv7hftinyproxy-1.10.0nb2.tgz
NetBSD 8.0i386tinyproxy-1.10.0nb2.tgz
NetBSD 8.0i386tinyproxy-1.10.0nb2.tgz
NetBSD 8.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 8.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 8.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 8.0powerpctinyproxy-1.11.0.tgz
NetBSD 8.0x86_64tinyproxy-1.10.0nb2.tgz
NetBSD 8.0x86_64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0aarch64tinyproxy-1.11.0.tgz
NetBSD 9.0aarch64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0aarch64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0alphatinyproxy-1.11.0.tgz
NetBSD 9.0alphatinyproxy-1.10.0nb2.tgz
NetBSD 9.0alphatinyproxy-1.10.0nb2.tgz
NetBSD 9.0earmv6hftinyproxy-1.11.0.tgz
NetBSD 9.0earmv6hftinyproxy-1.10.0nb2.tgz
NetBSD 9.0earmv6hftinyproxy-1.10.0nb2.tgz
NetBSD 9.0earmv7hftinyproxy-1.11.0.tgz
NetBSD 9.0earmv7hftinyproxy-1.10.0nb2.tgz
NetBSD 9.0earmv7hftinyproxy-1.10.0nb2.tgz
NetBSD 9.0earmv7hftinyproxy-1.11.0.tgz
NetBSD 9.0i386tinyproxy-1.10.0nb2.tgz
NetBSD 9.0i386tinyproxy-1.10.0nb2.tgz
NetBSD 9.0mips64ebtinyproxy-1.10.0nb2.tgz
NetBSD 9.0mips64ebtinyproxy-1.10.0nb2.tgz
NetBSD 9.0mips64ebtinyproxy-1.10.0nb2.tgz
NetBSD 9.0mips64ebtinyproxy-1.11.0.tgz
NetBSD 9.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 9.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 9.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 9.0powerpctinyproxy-1.10.0nb2.tgz
NetBSD 9.0powerpctinyproxy-1.11.0.tgz
NetBSD 9.0sparc64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0sparc64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0sparc64tinyproxy-1.11.0.tgz
NetBSD 9.0sparctinyproxy-1.10.0nb2.tgz
NetBSD 9.0sparctinyproxy-1.10.0nb2.tgz
NetBSD 9.0sparctinyproxy-1.10.0nb2.tgz
NetBSD 9.0sparctinyproxy-1.11.0.tgz
NetBSD 9.0x86_64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0x86_64tinyproxy-1.11.0.tgz
NetBSD 9.0x86_64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0x86_64tinyproxy-1.10.0nb2.tgz
NetBSD 9.0x86_64tinyproxy-1.11.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.