www/siege - The NetBSD Packages Collection

Website/webserver regression testing utility

Siege is an http regression testing and benchmarking utility. It was
designed to let web developers measure the performance of their code
under duress, to see how it will stand up to load on the internet.

Siege supports basic authentication, cookies, HTTP and HTTPS protocols.
It allows the user hit a web server with a configurable number of
concurrent simulated users. Those users place the webserver "under siege."

Build dependencies

pkgtools/cwrappers devel/autoconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsiege-4.0.7.tgz
NetBSD 8.0earmv7hfsiege-4.0.7.tgz
NetBSD 8.0earmv7hfsiege-4.0.7.tgz
NetBSD 8.0i386siege-4.0.7.tgz
NetBSD 8.0i386siege-4.0.7.tgz
NetBSD 8.0powerpcsiege-4.0.7.tgz
NetBSD 8.0powerpcsiege-4.0.7.tgz
NetBSD 8.0powerpcsiege-4.0.7.tgz
NetBSD 8.0powerpcsiege-4.0.7.tgz
NetBSD 8.0x86_64siege-4.0.7.tgz
NetBSD 8.0x86_64siege-4.0.7.tgz
NetBSD 9.0aarch64siege-4.0.7.tgz
NetBSD 9.0aarch64siege-4.0.7.tgz
NetBSD 9.0aarch64siege-4.0.7.tgz
NetBSD 9.0alphasiege-4.0.7.tgz
NetBSD 9.0alphasiege-4.0.7.tgz
NetBSD 9.0alphasiege-4.0.7.tgz
NetBSD 9.0earmsiege-4.0.7.tgz
NetBSD 9.0earmsiege-4.0.7.tgz
NetBSD 9.0earmsiege-4.0.7.tgz
NetBSD 9.0earmv6hfsiege-4.0.7.tgz
NetBSD 9.0earmv6hfsiege-4.0.7.tgz
NetBSD 9.0earmv6hfsiege-4.0.7.tgz
NetBSD 9.0earmv7hfsiege-4.0.7.tgz
NetBSD 9.0earmv7hfsiege-4.0.7.tgz
NetBSD 9.0earmv7hfsiege-4.0.7.tgz
NetBSD 9.0earmv7hfsiege-4.0.7.tgz
NetBSD 9.0i386siege-4.0.7.tgz
NetBSD 9.0i386siege-4.0.7.tgz
NetBSD 9.0mips64ebsiege-4.0.7.tgz
NetBSD 9.0mips64ebsiege-4.0.4nb1.tgz
NetBSD 9.0mips64ebsiege-4.0.7.tgz
NetBSD 9.0mips64ebsiege-4.0.7.tgz
NetBSD 9.0powerpcsiege-4.0.7.tgz
NetBSD 9.0powerpcsiege-4.0.7.tgz
NetBSD 9.0powerpcsiege-4.0.7.tgz
NetBSD 9.0powerpcsiege-4.0.7.tgz
NetBSD 9.0sparc64siege-4.0.7.tgz
NetBSD 9.0sparc64siege-4.0.7.tgz
NetBSD 9.0sparc64siege-4.0.7.tgz
NetBSD 9.0sparcsiege-4.0.7.tgz
NetBSD 9.0sparcsiege-4.0.4nb1.tgz
NetBSD 9.0sparcsiege-4.0.7.tgz
NetBSD 9.0sparcsiege-4.0.7.tgz
NetBSD 9.0x86_64siege-4.0.7.tgz
NetBSD 9.0x86_64siege-4.0.7.tgz
NetBSD 9.0x86_64siege-4.0.7.tgz
NetBSD 9.0x86_64siege-4.0.7.tgz
NetBSD 9.0x86_64siege-4.0.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

ssl
Enable SSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.