www/ruby-rails70 - The NetBSD Packages Collection

Full-stack web application framework, Rails 7.0

Ruby on Rails

Rails is a web-application framework that includes everything needed to
create database-backed web applications according to the
Model-View-Controller (MVC) pattern.

This is meta gem package for Ruby on Rails 7.0.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

mail/ruby-actionmailer70 www/ruby-actioncable70 mail/ruby-actionmailbox70 textproc/ruby-actiontext70 devel/ruby-railties70 lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ruby27-rails70-7.0.2.4.tgz
NetBSD 8.0i386ruby30-rails70-7.0.2.4.tgz
NetBSD 8.0i386ruby31-rails70-7.0.2.4.tgz
NetBSD 8.0i386ruby27-rails70-7.0.3.1.tgz
NetBSD 8.0i386ruby30-rails70-7.0.3.1.tgz
NetBSD 8.0i386ruby31-rails70-7.0.3.1.tgz
NetBSD 8.0powerpcruby27-rails70-7.0.0.tgz
NetBSD 8.0x86_64ruby27-rails70-7.0.3.1.tgz
NetBSD 8.0x86_64ruby30-rails70-7.0.3.1.tgz
NetBSD 8.0x86_64ruby31-rails70-7.0.3.1.tgz
NetBSD 8.0x86_64ruby27-rails70-7.0.2.4.tgz
NetBSD 8.0x86_64ruby30-rails70-7.0.2.4.tgz
NetBSD 8.0x86_64ruby31-rails70-7.0.2.4.tgz
NetBSD 9.0aarch64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0aarch64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0aarch64ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0aarch64ruby27-rails70-7.0.2.4.tgz
NetBSD 9.0aarch64ruby30-rails70-7.0.2.4.tgz
NetBSD 9.0aarch64ruby31-rails70-7.0.2.4.tgz
NetBSD 9.0alpharuby27-rails70-7.0.0.tgz
NetBSD 9.0alpharuby27-rails70-7.0.1.tgz
NetBSD 9.0alpharuby27-rails70-7.0.2.3.tgz
NetBSD 9.0alpharuby27-rails70-7.0.2.4.tgz
NetBSD 9.0alpharuby27-rails70-7.0.3.1.tgz
NetBSD 9.0earmv6hfruby27-rails70-7.0.3.1.tgz
NetBSD 9.0earmv6hfruby30-rails70-7.0.3.1.tgz
NetBSD 9.0earmv6hfruby31-rails70-7.0.3.1.tgz
NetBSD 9.0earmv6hfruby27-rails70-7.0.2.4.tgz
NetBSD 9.0earmv6hfruby30-rails70-7.0.2.4.tgz
NetBSD 9.0earmv6hfruby31-rails70-7.0.2.4.tgz
NetBSD 9.0earmv7hfruby27-rails70-7.0.2.4.tgz
NetBSD 9.0earmv7hfruby30-rails70-7.0.2.4.tgz
NetBSD 9.0earmv7hfruby31-rails70-7.0.2.4.tgz
NetBSD 9.0earmv7hfruby27-rails70-7.0.3.1.tgz
NetBSD 9.0earmv7hfruby30-rails70-7.0.3.1.tgz
NetBSD 9.0earmv7hfruby31-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby27-rails70-7.0.2.4.tgz
NetBSD 9.0i386ruby30-rails70-7.0.2.4.tgz
NetBSD 9.0i386ruby31-rails70-7.0.2.4.tgz
NetBSD 9.0i386ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0i386ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0powerpcruby27-rails70-7.0.0.tgz
NetBSD 9.0powerpcruby30-rails70-7.0.0.tgz
NetBSD 9.0sparc64ruby27-rails70-7.0.0.tgz
NetBSD 9.0sparc64ruby30-rails70-7.0.0.tgz
NetBSD 9.0sparc64ruby27-rails70-7.0.2.3.tgz
NetBSD 9.0sparc64ruby30-rails70-7.0.2.3.tgz
NetBSD 9.0sparc64ruby31-rails70-7.0.2.3.tgz
NetBSD 9.0sparc64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0sparc64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0sparc64ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.3.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.3.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.3.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.2.4.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.2.4.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.2.4.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.2.3.tgz
NetBSD 9.0x86_64ruby27-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby30-rails70-7.0.3.1.tgz
NetBSD 9.0x86_64ruby31-rails70-7.0.3.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.