www/ruby-compass-susy-plugin - The NetBSD Packages Collection

Compass plugin grid system

Susy is a semantic CSS framework creator entirely native to Compass.
Susy is an expert at fluid grids in an elastic (or fluid, or fixed)
shell that will never activate that bloody side-scroll bar. Susy
sets your width on the outer element (`container`), adds a `max-width`
of `100%` and builds the rest of your grid in percentages. The
philosophy and technique are based on Natalie Downe's "CSS Systems"
- which introduces difficult math in the service of beautiful
structure. With the power of Compass/Sass, Susy will do that math
for you.

Using simple mixins, columns can be created, suffixed, prefixed,
and nested easily - and always in flexible percentages.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/ruby-compass lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0i386ruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0i386ruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0i386ruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0i386ruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0i386ruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0x86_64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 8.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 8.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 8.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0aarch64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0alpharuby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv6hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0earmv7hfruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0i386ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0mips64ebruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby24-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0powerpcruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0sparc64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby25-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby30-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby26-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby27-compass-susy-plugin-0.9.tgz
NetBSD 9.0x86_64ruby30-compass-susy-plugin-0.9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.