www/php-http - The NetBSD Packages Collection

PHP extension for extended HTTP support

This HTTP extension aims to provide a convenient and powerful
set of functionality for one of PHPs major applications.

It eases handling of HTTP urls, dates, redirects, headers and
messages, provides means for negotiation of clients preferred
language and charset, as well as a convenient way to send any
arbitrary data with caching and resuming capabilities.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf

Runtime dependencies

devel/libidn devel/php-raphf www/curl www/php-propro converters/php-iconv lang/php56 devel/libidn www/curl lang/php56

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfphp56-http-2.6.0nb15.tgz
NetBSD 8.0earmv7hfphp56-http-2.6.0nb14.tgz
NetBSD 8.0earmv7hfphp56-http-2.6.0nb15.tgz
NetBSD 8.0i386php56-http-2.6.0nb14.tgz
NetBSD 8.0i386php56-http-2.6.0nb15.tgz
NetBSD 8.0powerpcphp56-http-2.6.0nb14.tgz
NetBSD 8.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 8.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 8.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 8.0x86_64php56-http-2.6.0nb14.tgz
NetBSD 8.0x86_64php56-http-2.6.0nb15.tgz
NetBSD 9.0aarch64php56-http-2.6.0nb15.tgz
NetBSD 9.0aarch64php56-http-2.6.0nb14.tgz
NetBSD 9.0aarch64php56-http-2.6.0nb15.tgz
NetBSD 9.0alphaphp56-http-2.6.0nb15.tgz
NetBSD 9.0alphaphp56-http-2.6.0nb14.tgz
NetBSD 9.0alphaphp56-http-2.6.0nb15.tgz
NetBSD 9.0earmv6hfphp56-http-2.6.0nb15.tgz
NetBSD 9.0earmv6hfphp56-http-2.6.0nb14.tgz
NetBSD 9.0earmv6hfphp56-http-2.6.0nb15.tgz
NetBSD 9.0earmv7hfphp56-http-2.6.0nb15.tgz
NetBSD 9.0earmv7hfphp56-http-2.6.0nb14.tgz
NetBSD 9.0earmv7hfphp56-http-2.6.0nb15.tgz
NetBSD 9.0earmv7hfphp56-http-2.6.0nb15.tgz
NetBSD 9.0i386php56-http-2.6.0nb14.tgz
NetBSD 9.0i386php56-http-2.6.0nb15.tgz
NetBSD 9.0mips64ebphp56-http-2.6.0nb15.tgz
NetBSD 9.0mips64ebphp56-http-2.6.0nb14.tgz
NetBSD 9.0mips64ebphp56-http-2.6.0nb14.tgz
NetBSD 9.0mips64ebphp56-http-2.6.0nb15.tgz
NetBSD 9.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 9.0powerpcphp56-http-2.6.0nb14.tgz
NetBSD 9.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 9.0powerpcphp56-http-2.6.0nb15.tgz
NetBSD 9.0sparc64php56-http-2.6.0nb15.tgz
NetBSD 9.0sparc64php56-http-2.6.0nb14.tgz
NetBSD 9.0sparc64php56-http-2.6.0nb15.tgz
NetBSD 9.0sparcphp56-http-2.6.0nb15.tgz
NetBSD 9.0sparcphp56-http-2.6.0nb15.tgz
NetBSD 9.0x86_64php56-http-2.6.0nb15.tgz
NetBSD 9.0x86_64php56-http-2.6.0nb15.tgz
NetBSD 9.0x86_64php56-http-2.6.0nb14.tgz
NetBSD 9.0x86_64php56-http-2.6.0nb15.tgz
NetBSD 9.0x86_64php56-http-2.6.0nb15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.