www/php-dotclear - The NetBSD Packages Collection

Open-source web publising software

Dotclear's proposed aim is to develop a software that fully respects web
standards based on open source solutions, with multilingual interface and
publishing capabilities. It is written in PHP.
Notable features include handling many blogs, using Wiki or XHTML syntax for
entries, adding pages that are independent from the flow of entries and support
for several database types: (MySQL, PostgreSQL, SQLite).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

converters/php-mbstring converters/php-iconv textproc/php-json archivers/php-zlib databases/php-mysqli

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfphp56-dotclear-2.18.1nb1.tgz
NetBSD 8.0earmv7hfphp73-dotclear-2.18.1nb1.tgz
NetBSD 8.0earmv7hfphp74-dotclear-2.18.1nb1.tgz
NetBSD 8.0earmv7hfphp80-dotclear-2.18.1nb1.tgz
NetBSD 8.0powerpcphp56-dotclear-2.18.1nb1.tgz
NetBSD 8.0powerpcphp73-dotclear-2.18.1nb1.tgz
NetBSD 8.0powerpcphp74-dotclear-2.18.1nb1.tgz
NetBSD 8.0powerpcphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0aarch64php56-dotclear-2.18.1nb1.tgz
NetBSD 9.0aarch64php73-dotclear-2.18.1nb1.tgz
NetBSD 9.0aarch64php74-dotclear-2.18.1nb1.tgz
NetBSD 9.0aarch64php80-dotclear-2.18.1nb1.tgz
NetBSD 9.0alphaphp56-dotclear-2.18.1nb1.tgz
NetBSD 9.0alphaphp73-dotclear-2.18.1nb1.tgz
NetBSD 9.0alphaphp74-dotclear-2.18.1nb1.tgz
NetBSD 9.0alphaphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv6hfphp56-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv6hfphp73-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv6hfphp74-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv6hfphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp56-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp73-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp74-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp56-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp73-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp74-dotclear-2.18.1nb1.tgz
NetBSD 9.0earmv7hfphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0powerpcphp56-dotclear-2.18.1nb1.tgz
NetBSD 9.0powerpcphp73-dotclear-2.18.1nb1.tgz
NetBSD 9.0powerpcphp74-dotclear-2.18.1nb1.tgz
NetBSD 9.0powerpcphp80-dotclear-2.18.1nb1.tgz
NetBSD 9.0sparc64php56-dotclear-2.18.1nb1.tgz
NetBSD 9.0sparc64php73-dotclear-2.18.1nb1.tgz
NetBSD 9.0sparc64php74-dotclear-2.18.1nb1.tgz
NetBSD 9.0sparc64php80-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php56-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php73-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php74-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php80-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php56-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php73-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php74-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php80-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php56-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php73-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php74-dotclear-2.18.1nb1.tgz
NetBSD 9.0x86_64php80-dotclear-2.18.1nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mysql
Enable MySQL support.
pgsql
Enable PostgreSQL support.
sqlite
Enable SQLite support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.