www/p5-libapreq2 - The NetBSD Packages Collection

Lots of Apache specific httpd handling modules

This package contains modules for manipulating client request data via
the Apache API with Perl and C.  Functionality includes:

 - parsing of application/x-www-form-urlencoded data
 - parsing of multipart/form-data
 - parsing of HTTP Cookies

Build dependencies

www/apache24 www/apache24 pkgtools/cwrappers www/apache24 devel/libtool-base devel/gmake lang/perl5

Runtime dependencies

devel/p5-ExtUtils-XSBuilder lang/perl5 lang/perl5 www/ap2-perl www/ap2-perl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-ap24-libapreq2-2.16.tgz
NetBSD 8.0earmv7hfp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0earmv7hfp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 8.0i386p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0i386p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 8.0powerpcp5-ap24-libapreq2-2.16.tgz
NetBSD 8.0x86_64p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 8.0x86_64p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0aarch64p5-ap24-libapreq2-2.16.tgz
NetBSD 9.0aarch64p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0aarch64p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0alphap5-ap24-libapreq2-2.16.tgz
NetBSD 9.0alphap5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0alphap5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0earmp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0earmp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0earmv6hfp5-ap24-libapreq2-2.16.tgz
NetBSD 9.0earmv6hfp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0earmv6hfp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0earmv7hfp5-ap24-libapreq2-2.16.tgz
NetBSD 9.0earmv7hfp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0earmv7hfp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0earmv7hfp5-ap24-libapreq2-2.16.tgz
NetBSD 9.0i386p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0i386p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0mips64ebp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0mips64ebp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0mips64ebp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0mips64ebp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0mips64ebp5-ap24-libapreq2-2.16.tgz
NetBSD 9.0mipselp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0mipselp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb4.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0powerpcp5-ap24-libapreq2-2.16.tgz
NetBSD 9.0sh3elp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0sh3elp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0sh3elp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0sparc64p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0sparc64p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0sparc64p5-ap24-libapreq2-2.16.tgz
NetBSD 9.0sparcp5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0sparcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0sparcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0sparcp5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0x86_64p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0x86_64p5-ap24-libapreq2-2.16.tgz
NetBSD 9.0x86_64p5-ap24-libapreq2-2.13nb5.tgz
NetBSD 9.0x86_64p5-ap24-libapreq2-2.13nb6.tgz
NetBSD 9.0x86_64p5-ap24-libapreq2-2.16.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.