www/p5-WWW-Shorten - The NetBSD Packages Collection

Perl 5 module interface to URL shortening sites

The Perl 5 module WWW::Shorten provides an interface to URL shortening
sites. These sites maintain databases of long URLs, each of which
has a unique identifier. A very simple program called shorten is
supplied. This program takes a URL and gives you a shortened version
of it.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Config-Auto www/p5-URI www/p5-libwww lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-WWW-Shorten-3.094.tgz
NetBSD 8.0earmv7hfp5-WWW-Shorten-3.093nb4.tgz
NetBSD 8.0earmv7hfp5-WWW-Shorten-3.093nb5.tgz
NetBSD 8.0i386p5-WWW-Shorten-3.093nb4.tgz
NetBSD 8.0i386p5-WWW-Shorten-3.093nb5.tgz
NetBSD 8.0powerpcp5-WWW-Shorten-3.093nb4.tgz
NetBSD 8.0powerpcp5-WWW-Shorten-3.093nb5.tgz
NetBSD 8.0powerpcp5-WWW-Shorten-3.093nb5.tgz
NetBSD 8.0powerpcp5-WWW-Shorten-3.094.tgz
NetBSD 8.0x86_64p5-WWW-Shorten-3.093nb4.tgz
NetBSD 8.0x86_64p5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0aarch64p5-WWW-Shorten-3.094.tgz
NetBSD 9.0aarch64p5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0aarch64p5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0alphap5-WWW-Shorten-3.094.tgz
NetBSD 9.0alphap5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0alphap5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0earmp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0earmp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0earmv6hfp5-WWW-Shorten-3.094.tgz
NetBSD 9.0earmv6hfp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0earmv6hfp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0earmv7hfp5-WWW-Shorten-3.094.tgz
NetBSD 9.0earmv7hfp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0earmv7hfp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0earmv7hfp5-WWW-Shorten-3.094.tgz
NetBSD 9.0i386p5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0i386p5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0i386p5-WWW-Shorten-3.094.tgz
NetBSD 9.0mips64ebp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0mips64ebp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0mips64ebp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0mips64ebp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0mips64ebp5-WWW-Shorten-3.094.tgz
NetBSD 9.0powerpcp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0powerpcp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0powerpcp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0powerpcp5-WWW-Shorten-3.094.tgz
NetBSD 9.0sparc64p5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0sparc64p5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0sparc64p5-WWW-Shorten-3.094.tgz
NetBSD 9.0sparcp5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0sparcp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0sparcp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0sparcp5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0sparcp5-WWW-Shorten-3.094.tgz
NetBSD 9.0x86_64p5-WWW-Shorten-3.094.tgz
NetBSD 9.0x86_64p5-WWW-Shorten-3.094.tgz
NetBSD 9.0x86_64p5-WWW-Shorten-3.093nb4.tgz
NetBSD 9.0x86_64p5-WWW-Shorten-3.093nb5.tgz
NetBSD 9.0x86_64p5-WWW-Shorten-3.094.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.