www/p5-WWW-RobotRules - The NetBSD Packages Collection

Perl 5 module database of robots.txt-derived permissions

The Perl 5 module WWW::RobotRules parses /robots.txt files as specified
in "A Standard for Robot Exclusion", at
http://www.robotstxt.org/wc/norobots.htmls
Webmasters can use the /robots.txt file to forbid conforming robots
from accessing parts of their web site.

The parsed files are kept in a WWW::RobotRules object, and this object
provides methods to check if access to a given URL is prohibited.
The same WWW::RobotRules object can be used for one or more parsed
/robots.txt files on any number of hosts.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/p5-URI lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0earmv7hfp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 8.0earmv7hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0i386p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 8.0i386p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0powerpcp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 8.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 8.0x86_64p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 8.0x86_64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0aarch64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0aarch64p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0aarch64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0alphap5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0alphap5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0alphap5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0earmp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmv6hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmv6hfp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0earmv6hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmv7hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmv7hfp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0earmv7hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0earmv7hfp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0i386p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0i386p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0m68kp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0m68kp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0m68kp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0m68kp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0mips64ebp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0mips64ebp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0mips64ebp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0mips64ebp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0mips64ebp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0mipselp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0mipselp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0mipselp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0mipselp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0powerpcp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0powerpcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sh3elp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sh3elp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sh3elp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sh3elp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sh3elp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sparc64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sparc64p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sparc64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sparcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0sparcp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sparcp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sparcp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0sparcp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0vaxp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0vaxp5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0vaxp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0vaxp5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0x86_64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0x86_64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0x86_64p5-WWW-RobotRules-6.02nb9.tgz
NetBSD 9.0x86_64p5-WWW-RobotRules-6.02nb10.tgz
NetBSD 9.0x86_64p5-WWW-RobotRules-6.02nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.