www/p5-Twiggy - The NetBSD Packages Collection

AnyEvent HTTP server for PSGI

the Perl 5 module Twiggy is a lightweight and fast HTTP server with
unique features such as: PSGI, AnyEvent, fast header parser,
and superdaemon aware.

Build dependencies

sysutils/p5-Server-Starter devel/p5-Test-Requires net/p5-Test-TCP pkgtools/cwrappers

Runtime dependencies

devel/p5-EV www/p5-HTTP-Parser-XS devel/p5-AnyEvent www/p5-libwww www/p5-Plack devel/p5-Try-Tiny lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Twiggy-0.1025nb7.tgz
NetBSD 8.0earmv7hfp5-Twiggy-0.1025nb6.tgz
NetBSD 8.0earmv7hfp5-Twiggy-0.1025nb7.tgz
NetBSD 8.0i386p5-Twiggy-0.1025nb6.tgz
NetBSD 8.0i386p5-Twiggy-0.1025nb7.tgz
NetBSD 8.0powerpcp5-Twiggy-0.1025nb6.tgz
NetBSD 8.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 8.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 8.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 8.0x86_64p5-Twiggy-0.1025nb6.tgz
NetBSD 8.0x86_64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0aarch64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0aarch64p5-Twiggy-0.1025nb6.tgz
NetBSD 9.0aarch64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0alphap5-Twiggy-0.1025nb7.tgz
NetBSD 9.0alphap5-Twiggy-0.1025nb6.tgz
NetBSD 9.0alphap5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0earmp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmv6hfp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmv6hfp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0earmv6hfp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmv7hfp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmv7hfp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0earmv7hfp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0earmv7hfp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0i386p5-Twiggy-0.1025nb6.tgz
NetBSD 9.0i386p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0mips64ebp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0mips64ebp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0mips64ebp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0mips64ebp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0mips64ebp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0powerpcp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0powerpcp5-Twiggy-0.1025nb7.tgz
NetBSD 9.0sh3elp5-Twiggy-0.1025nb6.tgz
NetBSD 9.0sparc64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0sparc64p5-Twiggy-0.1025nb6.tgz
NetBSD 9.0sparc64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0x86_64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0x86_64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0x86_64p5-Twiggy-0.1025nb6.tgz
NetBSD 9.0x86_64p5-Twiggy-0.1025nb7.tgz
NetBSD 9.0x86_64p5-Twiggy-0.1025nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.