www/p5-Rose-URI - The NetBSD Packages Collection

URI class for easy and efficient manipulation of URI components

Rose::URI is an alternative to URI. Important differences include:

Rose::URI provides a rich set of query string manipulation methods.
Query parameters can be added, removed, and checked for their
existence. URI allows the entire query to be set or returned as a
whole via the query_form or query methods, and the URI::QueryParam
module provides a few more methods for query string manipulation.

Rose::URI supports query parameters with multiple values (e.g.
"a=1&a=2"). URI has limited support for this through query_form's
list return value. Better methods are available in URI::QueryParam.

Rose::URI uses Apache's C-based URI parsing and HTML escaping
functions when running in a mod_perl 1.x web server environment.

Rose::URI stores each URI "in pieces" (scheme, host, path, etc.)
and then assembles those pieces when the entire URI is needed as
a string. This technique is based on the assumption that the URI
will be manipulated many more times than it is stringified. If this
is not the case in your usage scenario, then URI may be a better
alternative.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Rose-Object www/p5-URI lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Rose-URI-1.02nb6.tgz
NetBSD 8.0earmv7hfp5-Rose-URI-1.02nb5.tgz
NetBSD 8.0earmv7hfp5-Rose-URI-1.02nb6.tgz
NetBSD 8.0i386p5-Rose-URI-1.02nb5.tgz
NetBSD 8.0i386p5-Rose-URI-1.02nb6.tgz
NetBSD 8.0powerpcp5-Rose-URI-1.02nb5.tgz
NetBSD 8.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 8.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 8.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 8.0x86_64p5-Rose-URI-1.02nb5.tgz
NetBSD 8.0x86_64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0aarch64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0aarch64p5-Rose-URI-1.02nb5.tgz
NetBSD 9.0aarch64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0alphap5-Rose-URI-1.02nb6.tgz
NetBSD 9.0alphap5-Rose-URI-1.02nb5.tgz
NetBSD 9.0alphap5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0earmp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmv6hfp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmv6hfp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0earmv6hfp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmv7hfp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmv7hfp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0earmv7hfp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0earmv7hfp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0i386p5-Rose-URI-1.02nb5.tgz
NetBSD 9.0i386p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0i386p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0m68kp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0m68kp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0m68kp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0mips64ebp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0mips64ebp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0mips64ebp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0mips64ebp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0mips64ebp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0mipselp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0mipselp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0mipselp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0mipselp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0powerpcp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0powerpcp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sh3elp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sh3elp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sh3elp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sh3elp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sh3elp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sparc64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sparc64p5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sparc64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sparcp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0sparcp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sparcp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sparcp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0sparcp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0vaxp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0vaxp5-Rose-URI-1.02nb5.tgz
NetBSD 9.0vaxp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0vaxp5-Rose-URI-1.02nb6.tgz
NetBSD 9.0x86_64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0x86_64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0x86_64p5-Rose-URI-1.02nb5.tgz
NetBSD 9.0x86_64p5-Rose-URI-1.02nb6.tgz
NetBSD 9.0x86_64p5-Rose-URI-1.02nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.