www/p5-Plack-Middleware-Deflater - The NetBSD Packages Collection

Plack middleware to compress response body with Gzip or Deflate

The Perl 5 module Plack::Middleware::Deflater is a middleware to
encode your response body in gzip or deflate, based on Accept-Encoding
HTTP request header. It would save the bandwidth a little bit but
should increase the Plack server load, so ideally you should handle
this on the frontend reverse proxy servers.

Build dependencies

devel/p5-Test-Requires pkgtools/cwrappers

Runtime dependencies

www/p5-Plack lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 8.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0i386p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 8.0i386p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0powerpcp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 8.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 8.0x86_64p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 8.0x86_64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0aarch64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0aarch64p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0aarch64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0alphap5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0alphap5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0alphap5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0earmv6hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0earmv6hfp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0earmv6hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0earmv7hfp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0i386p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0i386p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0mips64ebp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0mips64ebp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0mips64ebp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0mips64ebp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0powerpcp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0powerpcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0sparc64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0sparc64p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0sparc64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0sparcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0sparcp5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0sparcp5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0x86_64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0x86_64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0x86_64p5-Plack-Middleware-Deflater-0.12nb6.tgz
NetBSD 9.0x86_64p5-Plack-Middleware-Deflater-0.12nb7.tgz
NetBSD 9.0x86_64p5-Plack-Middleware-Deflater-0.12nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.