www/p5-PSGI - The NetBSD Packages Collection

Perl Web Server Gateway Interface Specification

PSGI specifies a standard interface between web servers and Perl
web applications or frameworks, to promote web application portability
and reduce the duplicated efforts by web application framework
developers It is a specification to decouple web server environments
from web application framework code.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-PSGI-1.102nb8.tgz
NetBSD 8.0earmv7hfp5-PSGI-1.102nb7.tgz
NetBSD 8.0earmv7hfp5-PSGI-1.102nb8.tgz
NetBSD 8.0i386p5-PSGI-1.102nb7.tgz
NetBSD 8.0i386p5-PSGI-1.102nb8.tgz
NetBSD 8.0powerpcp5-PSGI-1.102nb7.tgz
NetBSD 8.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 8.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 8.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 8.0x86_64p5-PSGI-1.102nb7.tgz
NetBSD 8.0x86_64p5-PSGI-1.102nb8.tgz
NetBSD 9.0aarch64p5-PSGI-1.102nb8.tgz
NetBSD 9.0aarch64p5-PSGI-1.102nb7.tgz
NetBSD 9.0aarch64p5-PSGI-1.102nb8.tgz
NetBSD 9.0alphap5-PSGI-1.102nb8.tgz
NetBSD 9.0alphap5-PSGI-1.102nb7.tgz
NetBSD 9.0alphap5-PSGI-1.102nb8.tgz
NetBSD 9.0earmp5-PSGI-1.102nb7.tgz
NetBSD 9.0earmp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmv6hfp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmv6hfp5-PSGI-1.102nb7.tgz
NetBSD 9.0earmv6hfp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmv7hfp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmv7hfp5-PSGI-1.102nb7.tgz
NetBSD 9.0earmv7hfp5-PSGI-1.102nb8.tgz
NetBSD 9.0earmv7hfp5-PSGI-1.102nb8.tgz
NetBSD 9.0i386p5-PSGI-1.102nb7.tgz
NetBSD 9.0i386p5-PSGI-1.102nb8.tgz
NetBSD 9.0mips64ebp5-PSGI-1.102nb8.tgz
NetBSD 9.0mips64ebp5-PSGI-1.102nb7.tgz
NetBSD 9.0mips64ebp5-PSGI-1.102nb7.tgz
NetBSD 9.0mips64ebp5-PSGI-1.102nb8.tgz
NetBSD 9.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 9.0powerpcp5-PSGI-1.102nb7.tgz
NetBSD 9.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 9.0powerpcp5-PSGI-1.102nb8.tgz
NetBSD 9.0sparc64p5-PSGI-1.102nb8.tgz
NetBSD 9.0sparc64p5-PSGI-1.102nb7.tgz
NetBSD 9.0sparc64p5-PSGI-1.102nb8.tgz
NetBSD 9.0sparcp5-PSGI-1.102nb8.tgz
NetBSD 9.0sparcp5-PSGI-1.102nb7.tgz
NetBSD 9.0sparcp5-PSGI-1.102nb7.tgz
NetBSD 9.0sparcp5-PSGI-1.102nb8.tgz
NetBSD 9.0x86_64p5-PSGI-1.102nb8.tgz
NetBSD 9.0x86_64p5-PSGI-1.102nb8.tgz
NetBSD 9.0x86_64p5-PSGI-1.102nb7.tgz
NetBSD 9.0x86_64p5-PSGI-1.102nb8.tgz
NetBSD 9.0x86_64p5-PSGI-1.102nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.