www/p5-Net-FastCGI - The NetBSD Packages Collection

Perl 5 module to build and parse FastCGI messages

The Perl 5 module Net::FastCGI aims to provide a complete API for
working with the FastCGI protocol.  The primary goal is to provide
a function oriented and object oriented API which are not tied to
a specific I/O model or framework.  Secondary goal is to provide
higher level tools/API which can be used for debugging and
interoperability testing.

Build dependencies

devel/p5-Test-Exception devel/p5-Test-HexString pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0earmv7hfp5-Net-FastCGI-0.14nb7.tgz
NetBSD 8.0earmv7hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0i386p5-Net-FastCGI-0.14nb7.tgz
NetBSD 8.0i386p5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0powerpcp5-Net-FastCGI-0.14nb7.tgz
NetBSD 8.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 8.0x86_64p5-Net-FastCGI-0.14nb7.tgz
NetBSD 8.0x86_64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0aarch64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0aarch64p5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0aarch64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0alphap5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0alphap5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0alphap5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0earmv6hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0earmv6hfp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0earmv6hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0earmv7hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0earmv7hfp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0earmv7hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0earmv7hfp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0i386p5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0i386p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0i386p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0mips64ebp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0mips64ebp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0mips64ebp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0mips64ebp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0powerpcp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0powerpcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0sparc64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0sparc64p5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0sparc64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0sparcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0sparcp5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0sparcp5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0x86_64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0x86_64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0x86_64p5-Net-FastCGI-0.14nb7.tgz
NetBSD 9.0x86_64p5-Net-FastCGI-0.14nb8.tgz
NetBSD 9.0x86_64p5-Net-FastCGI-0.14nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.