www/p5-Kwiki-PagePrivacy - The NetBSD Packages Collection

Kwiki page-level privacy plugin

Kwiki::PagePrivacy is a plugin that lets you mark individual pages as:

    * Public - normal readable/writable
    * Protected - readonly to everyone except the control group.
    * Private - invisible to everyone but the control group.

Each "view" or a point of entry into the kwiki has an associated
control (permissions) group.

Here is the typical setup process:

	kwiki -new mykwiki
	cd mykwiki
	kwiki -add Kwiki::PagePrivacy
	kwiki -new_view admin
	echo 'privacy_group: admin' > admin/config2.yaml

Don't forget to secure the admin view with something like Apache's
.htaccess files.  You only want people who are admins setting the
privacy levels.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/p5-Kwiki lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 8.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0i386p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 8.0i386p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0powerpcp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 8.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 8.0x86_64p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 8.0x86_64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0aarch64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0aarch64p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0aarch64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0alphap5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0alphap5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0alphap5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0earmv6hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0earmv6hfp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0earmv6hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0earmv7hfp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0i386p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0i386p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0mips64ebp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0mips64ebp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0mips64ebp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0mips64ebp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0powerpcp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0powerpcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0sparc64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0sparc64p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0sparc64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0sparcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0sparcp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0sparcp5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0sparcp5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0x86_64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0x86_64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0x86_64p5-Kwiki-PagePrivacy-0.10nb13.tgz
NetBSD 9.0x86_64p5-Kwiki-PagePrivacy-0.10nb14.tgz
NetBSD 9.0x86_64p5-Kwiki-PagePrivacy-0.10nb14.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.