www/p5-HTTP-OAI - The NetBSD Packages Collection

API for the OAI-PMH

HTTP::OAI is a stub module.

HTTP::OAI::Harvester is the harvesting front-end in the OAI-PERL library.

To harvest from an OAI-PMH compliant repository create an HTTP::OAI::Harvester
object using the baseURL option and then call OAI-PMH methods to request data
from the repository. To handle version 1.0/1.1 repositories automatically you
must request Identify() first.

It is recommended that you request an Identify from the Repository and use the
repository() method to update the Identify object used by the harvester.

When making OAI requests the underlying HTTP::OAI::UserAgent module will take
care of automatic redirection (http code 302) and retry-after (http code 503).
OAI-PMH flow control (i.e. resumption tokens) is handled transparently by
HTTP::OAI::Response.

Build dependencies

devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

textproc/p5-XML-LibXML textproc/p5-XML-SAX www/p5-URI www/p5-libwww lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-HTTP-OAI-4.11.tgz
NetBSD 8.0earmv7hfp5-HTTP-OAI-4.10nb1.tgz
NetBSD 8.0earmv7hfp5-HTTP-OAI-4.10nb2.tgz
NetBSD 8.0i386p5-HTTP-OAI-4.10nb1.tgz
NetBSD 8.0i386p5-HTTP-OAI-4.10nb2.tgz
NetBSD 8.0powerpcp5-HTTP-OAI-4.10nb1.tgz
NetBSD 8.0powerpcp5-HTTP-OAI-4.10nb2.tgz
NetBSD 8.0powerpcp5-HTTP-OAI-4.10nb2.tgz
NetBSD 8.0powerpcp5-HTTP-OAI-4.11.tgz
NetBSD 8.0x86_64p5-HTTP-OAI-4.10nb1.tgz
NetBSD 8.0x86_64p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0aarch64p5-HTTP-OAI-4.11.tgz
NetBSD 9.0aarch64p5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0aarch64p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0alphap5-HTTP-OAI-4.11.tgz
NetBSD 9.0alphap5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0alphap5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0earmv6hfp5-HTTP-OAI-4.11.tgz
NetBSD 9.0earmv6hfp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0earmv6hfp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0earmv7hfp5-HTTP-OAI-4.11.tgz
NetBSD 9.0earmv7hfp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0earmv7hfp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0earmv7hfp5-HTTP-OAI-4.11.tgz
NetBSD 9.0i386p5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0i386p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0mips64ebp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0mips64ebp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0mips64ebp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0mips64ebp5-HTTP-OAI-4.11.tgz
NetBSD 9.0powerpcp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0powerpcp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0powerpcp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0powerpcp5-HTTP-OAI-4.11.tgz
NetBSD 9.0sparc64p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0sparc64p5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0sparc64p5-HTTP-OAI-4.11.tgz
NetBSD 9.0sparcp5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0sparcp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0sparcp5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0x86_64p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0x86_64p5-HTTP-OAI-4.11.tgz
NetBSD 9.0x86_64p5-HTTP-OAI-4.10nb1.tgz
NetBSD 9.0x86_64p5-HTTP-OAI-4.10nb2.tgz
NetBSD 9.0x86_64p5-HTTP-OAI-4.11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.