www/p5-HTTP-Entity-Parser - The NetBSD Packages Collection

PSGI compliant HTTP Entity Parser

HTTP::Entity::Parser is PSGI compliant HTTP Entity parser. This module
also has compatibility with HTTP::Body. Unlike HTTP::Body, HTTP::Entity::Parser
reads HTTP entity from PSGI's env $env->{'psgi.input'} and parse it.
This module support application/x-www-form-urlencoded, multipart/form-data
and application/json.

Build dependencies

devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

converters/p5-JSON-MaybeXS www/p5-WWW-Form-UrlEncoded www/p5-HTTP-MultiPartParser devel/p5-Hash-MultiValue devel/p5-Stream-Buffered lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0earmv7hfp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 8.0earmv7hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0i386p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 8.0i386p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0powerpcp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 8.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 8.0x86_64p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 8.0x86_64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0aarch64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0aarch64p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0aarch64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0alphap5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0alphap5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0alphap5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0earmp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmv6hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmv6hfp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0earmv6hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmv7hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmv7hfp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0earmv7hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0earmv7hfp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0i386p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0i386p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0m68kp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0m68kp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0m68kp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0m68kp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0mips64ebp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0mips64ebp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0mips64ebp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0mips64ebp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0mips64ebp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0mipselp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0mipselp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0mipselp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0mipselp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0powerpcp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0powerpcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sh3elp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sh3elp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0sh3elp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0sh3elp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0sh3elp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sparc64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sparc64p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0sparc64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sparcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0sparcp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0sparcp5-HTTP-Entity-Parser-0.24.tgz
NetBSD 9.0sparcp5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0sparcp5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0x86_64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0x86_64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0x86_64p5-HTTP-Entity-Parser-0.25.tgz
NetBSD 9.0x86_64p5-HTTP-Entity-Parser-0.25nb1.tgz
NetBSD 9.0x86_64p5-HTTP-Entity-Parser-0.25nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.