www/p5-Dancer - The NetBSD Packages Collection

Perl 5 lightweight yet powerful web application framework

Dancer is a web application framework designed to be as effortless
as possible for the developer, taking care of the boring bits as
easily as possible, yet staying out of your way and letting you get
on with writing your code.

Dancer aims to provide the simplest way for writing web applications,
and offers the flexibility to scale between a very simple lightweight
web service consisting of a few lines of code in a single file, all
the way up to a more complex fully-fledged web application with
session support, templates for views and layouts, etc.

Build dependencies

www/p5-CGI devel/p5-Devel-Hide www/p5-HTTP-CookieJar converters/p5-JSON devel/p5-Test-NoWarnings pkgtools/cwrappers

Runtime dependencies

devel/p5-Clone devel/p5-Data-Dump www/p5-libwww devel/p5-Hash-Merge-Simple www/p5-HTTP-Body www/p5-HTTP-Server-Simple-PSGI mail/p5-MIME-Types devel/p5-Module-Runtime www/p5-URI devel/p5-Test-Output net/p5-Test-TCP devel/p5-Test-Pod-Coverage devel/p5-Try-Tiny textproc/p5-YAML lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Dancer-1.3513nb2.tgz
NetBSD 8.0earmv7hfp5-Dancer-1.3513nb1.tgz
NetBSD 8.0earmv7hfp5-Dancer-1.3513nb2.tgz
NetBSD 8.0i386p5-Dancer-1.3513nb1.tgz
NetBSD 8.0i386p5-Dancer-1.3513nb2.tgz
NetBSD 8.0powerpcp5-Dancer-1.3513nb1.tgz
NetBSD 8.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 8.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 8.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 8.0x86_64p5-Dancer-1.3513nb1.tgz
NetBSD 8.0x86_64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0aarch64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0aarch64p5-Dancer-1.3513nb1.tgz
NetBSD 9.0aarch64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0alphap5-Dancer-1.3513nb2.tgz
NetBSD 9.0alphap5-Dancer-1.3513nb1.tgz
NetBSD 9.0alphap5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmp5-Dancer-1.3513nb1.tgz
NetBSD 9.0earmp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmv6hfp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmv6hfp5-Dancer-1.3513nb1.tgz
NetBSD 9.0earmv6hfp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmv7hfp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmv7hfp5-Dancer-1.3513nb1.tgz
NetBSD 9.0earmv7hfp5-Dancer-1.3513nb2.tgz
NetBSD 9.0earmv7hfp5-Dancer-1.3513nb2.tgz
NetBSD 9.0i386p5-Dancer-1.3513nb1.tgz
NetBSD 9.0i386p5-Dancer-1.3513nb2.tgz
NetBSD 9.0mips64ebp5-Dancer-1.3513nb2.tgz
NetBSD 9.0mips64ebp5-Dancer-1.3513nb1.tgz
NetBSD 9.0mips64ebp5-Dancer-1.3513nb1.tgz
NetBSD 9.0mips64ebp5-Dancer-1.3513nb1.tgz
NetBSD 9.0mips64ebp5-Dancer-1.3513nb2.tgz
NetBSD 9.0mipselp5-Dancer-1.3513nb2.tgz
NetBSD 9.0mipselp5-Dancer-1.3513nb1.tgz
NetBSD 9.0mipselp5-Dancer-1.3513nb1.tgz
NetBSD 9.0mipselp5-Dancer-1.3513nb2.tgz
NetBSD 9.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 9.0powerpcp5-Dancer-1.3513nb1.tgz
NetBSD 9.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 9.0powerpcp5-Dancer-1.3513nb2.tgz
NetBSD 9.0sh3elp5-Dancer-1.3513nb2.tgz
NetBSD 9.0sh3elp5-Dancer-1.3513nb1.tgz
NetBSD 9.0sh3elp5-Dancer-1.3513nb1.tgz
NetBSD 9.0sh3elp5-Dancer-1.3513nb2.tgz
NetBSD 9.0sparc64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0sparc64p5-Dancer-1.3513nb1.tgz
NetBSD 9.0sparc64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0sparcp5-Dancer-1.3513nb2.tgz
NetBSD 9.0sparcp5-Dancer-1.3513nb1.tgz
NetBSD 9.0sparcp5-Dancer-1.3513nb1.tgz
NetBSD 9.0sparcp5-Dancer-1.3513nb1.tgz
NetBSD 9.0sparcp5-Dancer-1.3513nb2.tgz
NetBSD 9.0x86_64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0x86_64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0x86_64p5-Dancer-1.3513nb1.tgz
NetBSD 9.0x86_64p5-Dancer-1.3513nb2.tgz
NetBSD 9.0x86_64p5-Dancer-1.3513nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.