www/p5-CGI-Minimal - The NetBSD Packages Collection

Perl5 module for simple CGI scripts

CGI::Minimal is a lightweight alternative to CGI.  It provides the _minimum_
functions needed for CGI such as form decoding (including file upload forms),
URL encoding and decoding, HTTP usable date generation (RFC1123 compliant
dates) and _basic_ escaping and unescaping of HTMLized text.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0earmv7hfp5-CGI-Minimal-1.30.tgz
NetBSD 8.0earmv7hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0i386p5-CGI-Minimal-1.30.tgz
NetBSD 8.0i386p5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0powerpcp5-CGI-Minimal-1.30.tgz
NetBSD 8.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 8.0x86_64p5-CGI-Minimal-1.30.tgz
NetBSD 8.0x86_64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0aarch64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0aarch64p5-CGI-Minimal-1.30.tgz
NetBSD 9.0aarch64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0alphap5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0alphap5-CGI-Minimal-1.30.tgz
NetBSD 9.0alphap5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmp5-CGI-Minimal-1.30.tgz
NetBSD 9.0earmp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmv6hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmv6hfp5-CGI-Minimal-1.30.tgz
NetBSD 9.0earmv6hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmv7hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmv7hfp5-CGI-Minimal-1.30.tgz
NetBSD 9.0earmv7hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0earmv7hfp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0i386p5-CGI-Minimal-1.30.tgz
NetBSD 9.0i386p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0mips64ebp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0mips64ebp5-CGI-Minimal-1.30.tgz
NetBSD 9.0mips64ebp5-CGI-Minimal-1.30.tgz
NetBSD 9.0mips64ebp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0powerpcp5-CGI-Minimal-1.30.tgz
NetBSD 9.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0powerpcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0sparc64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0sparc64p5-CGI-Minimal-1.30.tgz
NetBSD 9.0sparc64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0sparcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0sparcp5-CGI-Minimal-1.30.tgz
NetBSD 9.0sparcp5-CGI-Minimal-1.30.tgz
NetBSD 9.0sparcp5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0x86_64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0x86_64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0x86_64p5-CGI-Minimal-1.30.tgz
NetBSD 9.0x86_64p5-CGI-Minimal-1.30nb1.tgz
NetBSD 9.0x86_64p5-CGI-Minimal-1.30nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.