www/p5-Browser-Open - The NetBSD Packages Collection

Open a browser in a given URL

The functions optionaly exported by this module allows you to open URLs in
the user browser.

A set of known commands per OS-name is tested for presence, and the first
one found is executed. With an optional parameter, all known commands are
checked.

The "open_browser" uses the system() function to execute the command. If
you want more control, you can get the command with the "open_browser_cmd"
or "open_browser_cmd_all" functions and then use whatever method you want
to execute it.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Browser-Open-0.04nb3.tgz
NetBSD 8.0earmv7hfp5-Browser-Open-0.04nb2.tgz
NetBSD 8.0earmv7hfp5-Browser-Open-0.04nb3.tgz
NetBSD 8.0i386p5-Browser-Open-0.04nb2.tgz
NetBSD 8.0i386p5-Browser-Open-0.04nb3.tgz
NetBSD 8.0powerpcp5-Browser-Open-0.04nb2.tgz
NetBSD 8.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 8.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 8.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 8.0x86_64p5-Browser-Open-0.04nb2.tgz
NetBSD 8.0x86_64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0aarch64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0aarch64p5-Browser-Open-0.04nb2.tgz
NetBSD 9.0aarch64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0alphap5-Browser-Open-0.04nb3.tgz
NetBSD 9.0alphap5-Browser-Open-0.04nb2.tgz
NetBSD 9.0alphap5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0earmp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmv6hfp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmv6hfp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0earmv6hfp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmv7hfp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmv7hfp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0earmv7hfp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0earmv7hfp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0i386p5-Browser-Open-0.04nb2.tgz
NetBSD 9.0i386p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0i386p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0m68kp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0m68kp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0mips64ebp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0mips64ebp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0mips64ebp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0mips64ebp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0mips64ebp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0mipselp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0mipselp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0mipselp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0mipselp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0powerpcp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0powerpcp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sh3elp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sh3elp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sh3elp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sh3elp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sparc64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sparc64p5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sparc64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sparcp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0sparcp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sparcp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sparcp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0sparcp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0vaxp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0vaxp5-Browser-Open-0.04nb2.tgz
NetBSD 9.0vaxp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0vaxp5-Browser-Open-0.04nb3.tgz
NetBSD 9.0x86_64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0x86_64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0x86_64p5-Browser-Open-0.04nb2.tgz
NetBSD 9.0x86_64p5-Browser-Open-0.04nb3.tgz
NetBSD 9.0x86_64p5-Browser-Open-0.04nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.