www/p5-Apache2-AuthCookieDBI - The NetBSD Packages Collection

Perl5 module AuthCookie backed by a DBI database

Apache::AuthCookieDBI is a module that subclasses Apache::AuthCookie and is
designed to be directly used for authentication in a mod_perl server.

It is a ticket-issuing system that looks up username/passwords in a DBI
database using generic SQL and issues MD5-checksummed tickets valid for
a configurable time period.  Incoming requests with tickets are
checksummed and expire-time checked.

Build dependencies

www/apache24 pkgtools/cwrappers www/apache24 lang/perl5

Runtime dependencies

www/p5-Apache2-AuthCookie databases/p5-DBI devel/p5-Date-Calc www/ap2-perl lang/perl5 lang/perl5 www/ap2-perl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0earmv7hfp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 8.0earmv7hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0i386p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 8.0i386p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0powerpcp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 8.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 8.0x86_64p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 8.0x86_64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0aarch64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0aarch64p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0aarch64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0alphap5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0alphap5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0alphap5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0earmv6hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0earmv6hfp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0earmv6hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0earmv7hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0earmv7hfp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0earmv7hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0earmv7hfp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0i386p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0i386p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0mips64ebp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0mips64ebp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0mips64ebp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0mips64ebp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0powerpcp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0powerpcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0sparc64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0sparc64p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0sparc64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0sparcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0sparcp5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0sparcp5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0x86_64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0x86_64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0x86_64p5-Apache2-AuthCookieDBI-2.19.tgz
NetBSD 9.0x86_64p5-Apache2-AuthCookieDBI-2.19nb1.tgz
NetBSD 9.0x86_64p5-Apache2-AuthCookieDBI-2.19nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.