www/htdavlock - The NetBSD Packages Collection

Apache mod_dav_fs lock database management tool

This is an Apache mod_davv_fs lock database management tool.

Sometimes a program crashes, leaving stale a lock on a WebDAV-based file.
This tool can inspect the lock database, and remove a stale lock.

The alternative is to wait for lock expiration.

Build dependencies

www/apache24 pkgtools/cwrappers www/apache24 lang/perl5 devel/pkgconf

Runtime dependencies

devel/apr devel/apr-util www/curl devel/apr-util www/curl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfhtdavlock-0.2nb11.tgz
NetBSD 8.0earmv7hfhtdavlock-0.2nb10.tgz
NetBSD 8.0earmv7hfhtdavlock-0.2nb11.tgz
NetBSD 8.0i386htdavlock-0.2nb10.tgz
NetBSD 8.0i386htdavlock-0.2nb11.tgz
NetBSD 8.0powerpchtdavlock-0.2nb10.tgz
NetBSD 8.0powerpchtdavlock-0.2nb11.tgz
NetBSD 8.0powerpchtdavlock-0.2nb11.tgz
NetBSD 8.0powerpchtdavlock-0.2nb11.tgz
NetBSD 8.0x86_64htdavlock-0.2nb10.tgz
NetBSD 8.0x86_64htdavlock-0.2nb11.tgz
NetBSD 9.0aarch64htdavlock-0.2nb11.tgz
NetBSD 9.0aarch64htdavlock-0.2nb10.tgz
NetBSD 9.0aarch64htdavlock-0.2nb11.tgz
NetBSD 9.0alphahtdavlock-0.2nb11.tgz
NetBSD 9.0alphahtdavlock-0.2nb10.tgz
NetBSD 9.0alphahtdavlock-0.2nb11.tgz
NetBSD 9.0earmv6hfhtdavlock-0.2nb11.tgz
NetBSD 9.0earmv6hfhtdavlock-0.2nb10.tgz
NetBSD 9.0earmv6hfhtdavlock-0.2nb11.tgz
NetBSD 9.0earmv7hfhtdavlock-0.2nb11.tgz
NetBSD 9.0earmv7hfhtdavlock-0.2nb10.tgz
NetBSD 9.0earmv7hfhtdavlock-0.2nb11.tgz
NetBSD 9.0earmv7hfhtdavlock-0.2nb11.tgz
NetBSD 9.0i386htdavlock-0.2nb10.tgz
NetBSD 9.0i386htdavlock-0.2nb11.tgz
NetBSD 9.0i386htdavlock-0.2nb11.tgz
NetBSD 9.0mips64ebhtdavlock-0.2nb11.tgz
NetBSD 9.0mips64ebhtdavlock-0.2nb10.tgz
NetBSD 9.0mips64ebhtdavlock-0.2nb10.tgz
NetBSD 9.0mips64ebhtdavlock-0.2nb11.tgz
NetBSD 9.0powerpchtdavlock-0.2nb11.tgz
NetBSD 9.0powerpchtdavlock-0.2nb10.tgz
NetBSD 9.0powerpchtdavlock-0.2nb11.tgz
NetBSD 9.0powerpchtdavlock-0.2nb11.tgz
NetBSD 9.0sparc64htdavlock-0.2nb11.tgz
NetBSD 9.0sparc64htdavlock-0.2nb10.tgz
NetBSD 9.0sparc64htdavlock-0.2nb11.tgz
NetBSD 9.0sparchtdavlock-0.2nb11.tgz
NetBSD 9.0sparchtdavlock-0.2nb10.tgz
NetBSD 9.0sparchtdavlock-0.2nb10.tgz
NetBSD 9.0sparchtdavlock-0.2nb11.tgz
NetBSD 9.0x86_64htdavlock-0.2nb11.tgz
NetBSD 9.0x86_64htdavlock-0.2nb11.tgz
NetBSD 9.0x86_64htdavlock-0.2nb10.tgz
NetBSD 9.0x86_64htdavlock-0.2nb11.tgz
NetBSD 9.0x86_64htdavlock-0.2nb11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.