www/dansguardian - The NetBSD Packages Collection

Fast, featureful web content filter for Squid proxy servers

DansGuardian is a web content filtering proxy for Linux, FreeBSD, OpenBSD,
and Solaris. It relies on a proxy server, for all fetching.  The preferred
proxy is Squid, however, DansGuardian should work with any proxy server.

It filters using multiple methods, including:
  - URL and domain filtering
  - textual content filtering
  - PICS filtering
  - MIME-type filtering
  - file extension filtering
  - POST filtering
  - user filtering
  - client IP filtering
  - exception lists for most of the above

Build dependencies

pkgtools/cwrappers lang/perl5 devel/pkgconf

Runtime dependencies

devel/pcre devel/pcre

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdansguardian-2.12.0.3nb11.tgz
NetBSD 8.0earmv7hfdansguardian-2.12.0.3nb10.tgz
NetBSD 8.0earmv7hfdansguardian-2.12.0.3nb11.tgz
NetBSD 8.0i386dansguardian-2.12.0.3nb10.tgz
NetBSD 8.0i386dansguardian-2.12.0.3nb11.tgz
NetBSD 8.0powerpcdansguardian-2.12.0.3nb10.tgz
NetBSD 8.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 8.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 8.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 8.0x86_64dansguardian-2.12.0.3nb10.tgz
NetBSD 8.0x86_64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0aarch64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0aarch64dansguardian-2.12.0.3nb10.tgz
NetBSD 9.0aarch64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0alphadansguardian-2.12.0.3nb11.tgz
NetBSD 9.0alphadansguardian-2.12.0.3nb10.tgz
NetBSD 9.0alphadansguardian-2.12.0.3nb11.tgz
NetBSD 9.0earmv6hfdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0earmv6hfdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0earmv6hfdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0earmv7hfdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0earmv7hfdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0earmv7hfdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0earmv7hfdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0i386dansguardian-2.12.0.3nb10.tgz
NetBSD 9.0i386dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0mips64ebdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0mips64ebdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0mips64ebdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0mips64ebdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0powerpcdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0powerpcdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0sparc64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0sparc64dansguardian-2.12.0.3nb10.tgz
NetBSD 9.0sparc64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0sparcdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0sparcdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0sparcdansguardian-2.12.0.3nb10.tgz
NetBSD 9.0sparcdansguardian-2.12.0.3nb11.tgz
NetBSD 9.0x86_64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0x86_64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0x86_64dansguardian-2.12.0.3nb10.tgz
NetBSD 9.0x86_64dansguardian-2.12.0.3nb11.tgz
NetBSD 9.0x86_64dansguardian-2.12.0.3nb11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

clamd
commandline
debug
Enable debugging facilities in the package.
email

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.