www/bozohttpd - The NetBSD Packages Collection

Bozotic HTTP server; small and secure

bozohttpd is a small and secure HTTP version 1.1 server. Its main
feature is the lack of features, reducing the code size and improving
verifiability.

It supports CGI/1.1, HTTP/1.1, HTTP/1.0, HTTP/0.9, ~user translations,
virtual hosting support, as well as multiple IP-based servers on a
single machine. It is capable of servicing pages via the IPv6 protocol.
It has SSL support. It has no configuration file by design.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/lua53

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfbozohttpd-20210227nb1.tgz
NetBSD 8.0earmv7hfbozohttpd-20210227.tgz
NetBSD 8.0earmv7hfbozohttpd-20210227nb1.tgz
NetBSD 8.0i386bozohttpd-20210227.tgz
NetBSD 8.0i386bozohttpd-20210227nb1.tgz
NetBSD 8.0powerpcbozohttpd-20210227.tgz
NetBSD 8.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 8.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 8.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 8.0x86_64bozohttpd-20210227.tgz
NetBSD 8.0x86_64bozohttpd-20210227nb1.tgz
NetBSD 9.0aarch64bozohttpd-20210227nb1.tgz
NetBSD 9.0aarch64bozohttpd-20210227.tgz
NetBSD 9.0aarch64bozohttpd-20210227nb1.tgz
NetBSD 9.0alphabozohttpd-20210227nb1.tgz
NetBSD 9.0alphabozohttpd-20210227.tgz
NetBSD 9.0alphabozohttpd-20210227nb1.tgz
NetBSD 9.0earmbozohttpd-20210227.tgz
NetBSD 9.0earmbozohttpd-20210227nb1.tgz
NetBSD 9.0earmbozohttpd-20210227nb1.tgz
NetBSD 9.0earmv6hfbozohttpd-20210227nb1.tgz
NetBSD 9.0earmv6hfbozohttpd-20210227.tgz
NetBSD 9.0earmv6hfbozohttpd-20210227nb1.tgz
NetBSD 9.0earmv7hfbozohttpd-20210227nb1.tgz
NetBSD 9.0earmv7hfbozohttpd-20210227.tgz
NetBSD 9.0earmv7hfbozohttpd-20210227nb1.tgz
NetBSD 9.0earmv7hfbozohttpd-20210227nb1.tgz
NetBSD 9.0i386bozohttpd-20210227.tgz
NetBSD 9.0i386bozohttpd-20210227nb1.tgz
NetBSD 9.0i386bozohttpd-20210227nb1.tgz
NetBSD 9.0mips64ebbozohttpd-20210227nb1.tgz
NetBSD 9.0mips64ebbozohttpd-20190228nb1.tgz
NetBSD 9.0mips64ebbozohttpd-20201014.tgz
NetBSD 9.0mips64ebbozohttpd-20210227.tgz
NetBSD 9.0mips64ebbozohttpd-20210227nb1.tgz
NetBSD 9.0mipselbozohttpd-20210227nb1.tgz
NetBSD 9.0mipselbozohttpd-20201014.tgz
NetBSD 9.0mipselbozohttpd-20210227.tgz
NetBSD 9.0mipselbozohttpd-20210227nb1.tgz
NetBSD 9.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 9.0powerpcbozohttpd-20210227.tgz
NetBSD 9.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 9.0powerpcbozohttpd-20210227nb1.tgz
NetBSD 9.0sh3elbozohttpd-20210227nb1.tgz
NetBSD 9.0sh3elbozohttpd-20201014.tgz
NetBSD 9.0sh3elbozohttpd-20210227.tgz
NetBSD 9.0sh3elbozohttpd-20210227nb1.tgz
NetBSD 9.0sparc64bozohttpd-20210227nb1.tgz
NetBSD 9.0sparc64bozohttpd-20210227.tgz
NetBSD 9.0sparc64bozohttpd-20210227nb1.tgz
NetBSD 9.0sparcbozohttpd-20210227nb1.tgz
NetBSD 9.0sparcbozohttpd-20190228nb1.tgz
NetBSD 9.0sparcbozohttpd-20201014.tgz
NetBSD 9.0sparcbozohttpd-20210227.tgz
NetBSD 9.0sparcbozohttpd-20210227nb1.tgz
NetBSD 9.0vaxbozohttpd-20210227.tgz
NetBSD 9.0vaxbozohttpd-20201014.tgz
NetBSD 9.0vaxbozohttpd-20210227nb1.tgz
NetBSD 9.0vaxbozohttpd-20210227nb1.tgz
NetBSD 9.0x86_64bozohttpd-20210227nb1.tgz
NetBSD 9.0x86_64bozohttpd-20210227nb1.tgz
NetBSD 9.0x86_64bozohttpd-20210227.tgz
NetBSD 9.0x86_64bozohttpd-20210227nb1.tgz
NetBSD 9.0x86_64bozohttpd-20210227nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

lua
Enable Lua support.
ssl
Enable SSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.