textproc/tuc - The NetBSD Packages Collection

When cut doesn't cut it

tuc (when cut doesn't cut it)

We've all been there. You want to cut some string on a delimiter repeated in
a non-deterministic way. Maybe you even want to use negative indexes or replace
the delimiters in the cut part with something else... That's where tuc can help.

Build dependencies

lang/rust pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64tuc-0.8.0.tgz
NetBSD 10.0aarch64tuc-0.8.0.tgz
NetBSD 10.0earmv7hftuc-0.8.0.tgz
NetBSD 10.0earmv7hftuc-0.8.0.tgz
NetBSD 10.0i386tuc-0.8.0.tgz
NetBSD 10.0powerpctuc-0.8.0.tgz
NetBSD 10.0powerpctuc-0.8.0.tgz
NetBSD 10.0x86_64tuc-0.8.0.tgz
NetBSD 10.0x86_64tuc-0.8.0.tgz
NetBSD 8.0powerpctuc-0.8.0.tgz
NetBSD 8.0powerpctuc-0.8.0.tgz
NetBSD 8.0x86_64tuc-0.8.0.tgz
NetBSD 8.0x86_64tuc-0.8.0.tgz
NetBSD 9.0aarch64tuc-0.8.0.tgz
NetBSD 9.0aarch64tuc-0.8.0.tgz
NetBSD 9.0aarch64tuc-0.8.0.tgz
NetBSD 9.0earmv7hftuc-0.8.0.tgz
NetBSD 9.0earmv7hftuc-0.8.0.tgz
NetBSD 9.0earmv7hftuc-0.8.0.tgz
NetBSD 9.0i386tuc-0.8.0.tgz
NetBSD 9.0i386tuc-0.8.0.tgz
NetBSD 9.0i386tuc-0.8.0.tgz
NetBSD 9.0powerpctuc-0.8.0.tgz
NetBSD 9.0powerpctuc-0.8.0.tgz
NetBSD 9.0powerpctuc-0.8.0.tgz
NetBSD 9.0sparc64tuc-0.8.0.tgz
NetBSD 9.0sparc64tuc-0.8.0.tgz
NetBSD 9.0sparc64tuc-0.8.0.tgz
NetBSD 9.0x86_64tuc-0.8.0.tgz
NetBSD 9.0x86_64tuc-0.8.0.tgz
NetBSD 9.0x86_64tuc-0.8.0.tgz
NetBSD 9.0x86_64tuc-0.8.0.tgz
NetBSD 9.0x86_64tuc-0.8.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.