textproc/libxml++5.0 - The NetBSD Packages Collection

C++ wrapper for the libxml XML parser library (5.0 API)

libxml++ is a C++ wrapper for the libxml XML parser library. It has SAX and
DOM-like APIs, but does not attempt to conform exactly to the DOM
specifications because they are not aimed at C++. Its API is much simpler
than the underlying libxml C API.

This package follows the libxml++-5.0 API.

Build dependencies

devel/meson devel/glib2-tools lang/python310 pkgtools/mktools lang/perl5 devel/pkgconf pkgtools/cwrappers

Runtime dependencies

devel/glibmm2.68 textproc/libxml2 devel/glibmm2.68 textproc/libxml2

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64libxml++5.0-5.0.1nb3.tgz
NetBSD 10.0aarch64libxml++5.0-5.0.1nb4.tgz
NetBSD 10.0earmv6hflibxml++5.0-5.0.1nb3.tgz
NetBSD 10.0earmv6hflibxml++5.0-5.0.1nb4.tgz
NetBSD 10.0earmv7hflibxml++5.0-5.0.1nb3.tgz
NetBSD 10.0earmv7hflibxml++5.0-5.0.1nb4.tgz
NetBSD 10.0i386libxml++5.0-5.0.1nb3.tgz
NetBSD 10.0powerpclibxml++5.0-5.0.1nb3.tgz
NetBSD 10.0powerpclibxml++5.0-5.0.1nb3.tgz
NetBSD 10.0x86_64libxml++5.0-5.0.1nb4.tgz
NetBSD 10.0x86_64libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0aarch64libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0aarch64libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0aarch64libxml++5.0-5.0.1nb4.tgz
NetBSD 9.0alphalibxml++5.0-5.0.1nb1.tgz
NetBSD 9.0alphalibxml++5.0-5.0.1nb1.tgz
NetBSD 9.0alphalibxml++5.0-5.0.1nb2.tgz
NetBSD 9.0alphalibxml++5.0-5.0.1nb3.tgz
NetBSD 9.0alphalibxml++5.0-5.0.1nb4.tgz
NetBSD 9.0earmv6hflibxml++5.0-5.0.1nb2.tgz
NetBSD 9.0earmv6hflibxml++5.0-5.0.1nb3.tgz
NetBSD 9.0earmv6hflibxml++5.0-5.0.1nb4.tgz
NetBSD 9.0earmv7hflibxml++5.0-5.0.1nb3.tgz
NetBSD 9.0earmv7hflibxml++5.0-5.0.1nb4.tgz
NetBSD 9.0earmv7hflibxml++5.0-5.0.1nb2.tgz
NetBSD 9.0i386libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0i386libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0i386libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0mips64eblibxml++5.0-5.0.1nb1.tgz
NetBSD 9.0mips64eblibxml++5.0-5.0.1nb1.tgz
NetBSD 9.0powerpclibxml++5.0-5.0.1nb3.tgz
NetBSD 9.0powerpclibxml++5.0-5.0.1nb2.tgz
NetBSD 9.0powerpclibxml++5.0-5.0.1nb3.tgz
NetBSD 9.0sparc64libxml++5.0-5.0.1nb1.tgz
NetBSD 9.0sparc64libxml++5.0-5.0.1nb1.tgz
NetBSD 9.0sparc64libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0sparc64libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0sparclibxml++5.0-5.0.1.tgz
NetBSD 9.0sparclibxml++5.0-5.0.1nb2.tgz
NetBSD 9.0x86_64libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0x86_64libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0x86_64libxml++5.0-5.0.1nb2.tgz
NetBSD 9.0x86_64libxml++5.0-5.0.1nb3.tgz
NetBSD 9.0x86_64libxml++5.0-5.0.1nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.