textproc/bibparse - The NetBSD Packages Collection

Syntax checking tools for BibTeX bibliography databases

Bibparse, biblex, and bibunlex are programs for doing syntax checking
on BibTeX bibliography database files.

Biblex lexically analyzes BibTeX bibliography database files and
produces a lexical token stream from them.

Bibparse verifies a biblex or bibclean (available as a separate
package) lexical token stream or BibTeX database files.

Bibunlex reconstructs a BibTeX bibliography database file from
bibclean or biblex lexical analysis output.

Also included in this package is bibdup which checks for duplicate
abbreviations and entries in BibTeX bibliography database files.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfbibparse-1.06.tgz
NetBSD 8.0earmv7hfbibparse-1.06.tgz
NetBSD 8.0earmv7hfbibparse-1.06.tgz
NetBSD 8.0i386bibparse-1.06.tgz
NetBSD 8.0i386bibparse-1.06.tgz
NetBSD 8.0powerpcbibparse-1.06.tgz
NetBSD 8.0powerpcbibparse-1.06.tgz
NetBSD 8.0powerpcbibparse-1.06.tgz
NetBSD 8.0powerpcbibparse-1.06.tgz
NetBSD 8.0x86_64bibparse-1.06.tgz
NetBSD 8.0x86_64bibparse-1.06.tgz
NetBSD 9.0aarch64bibparse-1.06.tgz
NetBSD 9.0aarch64bibparse-1.06.tgz
NetBSD 9.0aarch64bibparse-1.06.tgz
NetBSD 9.0alphabibparse-1.06.tgz
NetBSD 9.0alphabibparse-1.06.tgz
NetBSD 9.0alphabibparse-1.06.tgz
NetBSD 9.0earmbibparse-1.06.tgz
NetBSD 9.0earmbibparse-1.06.tgz
NetBSD 9.0earmbibparse-1.06.tgz
NetBSD 9.0earmv6hfbibparse-1.06.tgz
NetBSD 9.0earmv6hfbibparse-1.06.tgz
NetBSD 9.0earmv6hfbibparse-1.06.tgz
NetBSD 9.0earmv7hfbibparse-1.06.tgz
NetBSD 9.0earmv7hfbibparse-1.06.tgz
NetBSD 9.0earmv7hfbibparse-1.06.tgz
NetBSD 9.0earmv7hfbibparse-1.06.tgz
NetBSD 9.0i386bibparse-1.06.tgz
NetBSD 9.0i386bibparse-1.06.tgz
NetBSD 9.0m68kbibparse-1.06.tgz
NetBSD 9.0m68kbibparse-1.06.tgz
NetBSD 9.0mips64ebbibparse-1.06.tgz
NetBSD 9.0mips64ebbibparse-1.06.tgz
NetBSD 9.0mips64ebbibparse-1.06.tgz
NetBSD 9.0mips64ebbibparse-1.06.tgz
NetBSD 9.0mips64ebbibparse-1.06.tgz
NetBSD 9.0powerpcbibparse-1.06.tgz
NetBSD 9.0powerpcbibparse-1.06.tgz
NetBSD 9.0powerpcbibparse-1.06.tgz
NetBSD 9.0powerpcbibparse-1.06.tgz
NetBSD 9.0sparc64bibparse-1.06.tgz
NetBSD 9.0sparc64bibparse-1.06.tgz
NetBSD 9.0sparc64bibparse-1.06.tgz
NetBSD 9.0sparcbibparse-1.06.tgz
NetBSD 9.0sparcbibparse-1.06.tgz
NetBSD 9.0sparcbibparse-1.06.tgz
NetBSD 9.0sparcbibparse-1.06.tgz
NetBSD 9.0x86_64bibparse-1.06.tgz
NetBSD 9.0x86_64bibparse-1.06.tgz
NetBSD 9.0x86_64bibparse-1.06.tgz
NetBSD 9.0x86_64bibparse-1.06.tgz
NetBSD 9.0x86_64bibparse-1.06.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.