security/libpreludedb-python - The NetBSD Packages Collection

Provides an interface to the database used to store IDMEF alerts

Prelude is a hybrid IDS consisting of multiple
sensors, managers, and a display console. This
is Prelude DB Library. It allow the interface
allowing Prelude to use a DBMS for alert storage.
While libprelude support a choice of MySQL or
postgreSQL, this package uses MySQL because it
was nearly an order of magnitude faster during
test operation.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

lang/python27 security/libpreludedb lang/python27 security/libpreludedb

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0earmv7hflibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 8.0earmv7hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0i386libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 8.0i386libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0powerpclibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 8.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 8.0x86_64libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 8.0x86_64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0aarch64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0aarch64libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0aarch64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0alphalibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0alphalibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0alphalibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmlibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0earmlibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmv6hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmv6hflibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0earmv6hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmv7hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmv7hflibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0earmv7hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0earmv7hflibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0i386libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0i386libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0i386libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0mips64eblibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0mips64eblibpreludedb-python-0.9.15.3nb21.tgz
NetBSD 9.0mips64eblibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0mips64eblibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0powerpclibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0powerpclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0sh3ellibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0sparc64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0sparc64libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0sparc64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0sparclibpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0sparclibpreludedb-python-0.9.15.3nb21.tgz
NetBSD 9.0sparclibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0sparclibpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0x86_64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0x86_64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0x86_64libpreludedb-python-0.9.15.3nb22.tgz
NetBSD 9.0x86_64libpreludedb-python-0.9.15.3nb24.tgz
NetBSD 9.0x86_64libpreludedb-python-0.9.15.3nb24.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.