security/libmcrypt - The NetBSD Packages Collection

Crypto algorithms library

Libmcrypt:

libmcrypt is the library which implements all the algorithms and
modes found in mcrypt. It is currently under development but it
seems to work pretty good.  Unlike most encryption libraries
libmcrypt does not have everything (random number generators,
hashes, hmac implementation, key exchange, public key encryption
etc.).  Libmcrypt only implements an interface to access block and
stream encryption algorithms. Its purpose was to assist in the
development of mcrypt by providing a uniform interface to access
several different encryption algorithms, so that the main program
is independent of the encryption algorithms and the modes used.

Libmcrypt supports the algorithms:
BLOWFISH, TWOFISH, DES, TripleDES, 3-WAY, SAFER-sk64, SAFER-sk128,
SAFER+, LOKI97, GOST, RC2, RC6, MARS, IDEA, RIJNDAEL-128 (AES),
RIJNDAEL-192, RIJNDAEL-256, SERPENT, CAST-128 (known as CAST5),
CAST-256, ARCFOUR and WAKE.  Block algorithms can be used in: CBC,
ECB, CFB and OFB (8 bit and n bit, where n is the size of the
algorithm's block length).

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 8.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 8.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 8.0i386libmcrypt-2.5.8.tgz
NetBSD 8.0i386libmcrypt-2.5.8.tgz
NetBSD 8.0powerpclibmcrypt-2.5.8.tgz
NetBSD 8.0powerpclibmcrypt-2.5.8.tgz
NetBSD 8.0powerpclibmcrypt-2.5.8.tgz
NetBSD 8.0powerpclibmcrypt-2.5.8.tgz
NetBSD 8.0x86_64libmcrypt-2.5.8.tgz
NetBSD 8.0x86_64libmcrypt-2.5.8.tgz
NetBSD 9.0aarch64libmcrypt-2.5.8.tgz
NetBSD 9.0aarch64libmcrypt-2.5.8.tgz
NetBSD 9.0aarch64libmcrypt-2.5.8.tgz
NetBSD 9.0alphalibmcrypt-2.5.8.tgz
NetBSD 9.0alphalibmcrypt-2.5.8.tgz
NetBSD 9.0alphalibmcrypt-2.5.8.tgz
NetBSD 9.0earmlibmcrypt-2.5.8.tgz
NetBSD 9.0earmlibmcrypt-2.5.8.tgz
NetBSD 9.0earmlibmcrypt-2.5.8.tgz
NetBSD 9.0earmv6hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv6hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv6hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 9.0earmv7hflibmcrypt-2.5.8.tgz
NetBSD 9.0i386libmcrypt-2.5.8.tgz
NetBSD 9.0i386libmcrypt-2.5.8.tgz
NetBSD 9.0i386libmcrypt-2.5.8.tgz
NetBSD 9.0m68klibmcrypt-2.5.8.tgz
NetBSD 9.0m68klibmcrypt-2.5.8.tgz
NetBSD 9.0m68klibmcrypt-2.5.8.tgz
NetBSD 9.0m68klibmcrypt-2.5.8.tgz
NetBSD 9.0mips64eblibmcrypt-2.5.8.tgz
NetBSD 9.0mips64eblibmcrypt-2.5.8.tgz
NetBSD 9.0mips64eblibmcrypt-2.5.8.tgz
NetBSD 9.0mips64eblibmcrypt-2.5.8.tgz
NetBSD 9.0mips64eblibmcrypt-2.5.8.tgz
NetBSD 9.0mipsellibmcrypt-2.5.8.tgz
NetBSD 9.0mipsellibmcrypt-2.5.8.tgz
NetBSD 9.0mipsellibmcrypt-2.5.8.tgz
NetBSD 9.0mipsellibmcrypt-2.5.8.tgz
NetBSD 9.0powerpclibmcrypt-2.5.8.tgz
NetBSD 9.0powerpclibmcrypt-2.5.8.tgz
NetBSD 9.0powerpclibmcrypt-2.5.8.tgz
NetBSD 9.0powerpclibmcrypt-2.5.8.tgz
NetBSD 9.0sh3ellibmcrypt-2.5.8.tgz
NetBSD 9.0sh3ellibmcrypt-2.5.8.tgz
NetBSD 9.0sh3ellibmcrypt-2.5.8.tgz
NetBSD 9.0sh3ellibmcrypt-2.5.8.tgz
NetBSD 9.0sh3ellibmcrypt-2.5.8.tgz
NetBSD 9.0sparc64libmcrypt-2.5.8.tgz
NetBSD 9.0sparc64libmcrypt-2.5.8.tgz
NetBSD 9.0sparc64libmcrypt-2.5.8.tgz
NetBSD 9.0sparclibmcrypt-2.5.8.tgz
NetBSD 9.0sparclibmcrypt-2.5.8.tgz
NetBSD 9.0sparclibmcrypt-2.5.8.tgz
NetBSD 9.0sparclibmcrypt-2.5.8.tgz
NetBSD 9.0sparclibmcrypt-2.5.8.tgz
NetBSD 9.0vaxlibmcrypt-2.5.8.tgz
NetBSD 9.0vaxlibmcrypt-2.5.8.tgz
NetBSD 9.0vaxlibmcrypt-2.5.8.tgz
NetBSD 9.0vaxlibmcrypt-2.5.8.tgz
NetBSD 9.0x86_64libmcrypt-2.5.8.tgz
NetBSD 9.0x86_64libmcrypt-2.5.8.tgz
NetBSD 9.0x86_64libmcrypt-2.5.8.tgz
NetBSD 9.0x86_64libmcrypt-2.5.8.tgz
NetBSD 9.0x86_64libmcrypt-2.5.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.