security/ipv6-toolkit - The NetBSD Packages Collection

IPv6 security assessment and troubleshooting tool

The SI6 Networks' IPv6 toolkit is a set of IPv6
security/trouble-shooting tools, that can send arbitrary IPv6-based
packets.

flow6:	A tool to perform a security asseessment of the IPv6 Flow Label.
frag6:  A tool to perform IPv6 fragmentation-based attacks and to
	perform a security assessment of a number of fragmentation-related
	aspects.
icmp6:	A tool to perform attacks based on ICMPv6 error messages.
jumbo6:	A tool to assess potential flaws in the handling of IPv6 Jumbograms.
na6:	A tool to send arbitrary Neighbor Advertisement messages.
ni6:	A tool to send arbitrary ICMPv6 Node Information messages, and
	assess possible flaws in the processing of such packets.
ns6:	A tool to send arbitrary Neighbor Solicitation messages.
ra6:	A tool to send arbitrary Router Advertisement messages.
rd6:	A tool to send arbitrary ICMPv6 Redirect messages.
rs6:	A tool to send arbitrary Router Solicitation messages.
scan6:	An IPv6 address scanning tool.
tcp6:	A tool to send arbitrary TCP segments and perform a variety of
	TCP-based attacks.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 8.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 8.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 8.0i386ipv6toolkit-1.4.1.tgz
NetBSD 8.0i386ipv6toolkit-1.4.1.tgz
NetBSD 8.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 8.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 8.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 8.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 8.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 8.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 9.0aarch64ipv6toolkit-1.4.1.tgz
NetBSD 9.0aarch64ipv6toolkit-1.4.1.tgz
NetBSD 9.0aarch64ipv6toolkit-1.4.1.tgz
NetBSD 9.0alphaipv6toolkit-1.4.1.tgz
NetBSD 9.0alphaipv6toolkit-1.4.1.tgz
NetBSD 9.0alphaipv6toolkit-1.4.1.tgz
NetBSD 9.0earmipv6toolkit-1.4.1.tgz
NetBSD 9.0earmipv6toolkit-1.4.1.tgz
NetBSD 9.0earmipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv6hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv6hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv6hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 9.0earmv7hfipv6toolkit-1.4.1.tgz
NetBSD 9.0i386ipv6toolkit-1.4.1.tgz
NetBSD 9.0i386ipv6toolkit-1.4.1.tgz
NetBSD 9.0m68kipv6toolkit-1.4.1.tgz
NetBSD 9.0m68kipv6toolkit-1.4.1.tgz
NetBSD 9.0mips64ebipv6toolkit-1.4.1.tgz
NetBSD 9.0mips64ebipv6toolkit-1.4.1.tgz
NetBSD 9.0mips64ebipv6toolkit-1.4.1.tgz
NetBSD 9.0mips64ebipv6toolkit-1.4.1.tgz
NetBSD 9.0mips64ebipv6toolkit-1.4.1.tgz
NetBSD 9.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 9.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 9.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 9.0powerpcipv6toolkit-1.4.1.tgz
NetBSD 9.0sparc64ipv6toolkit-1.4.1.tgz
NetBSD 9.0sparc64ipv6toolkit-1.4.1.tgz
NetBSD 9.0sparc64ipv6toolkit-1.4.1.tgz
NetBSD 9.0sparcipv6toolkit-1.4.1.tgz
NetBSD 9.0sparcipv6toolkit-1.4.1.tgz
NetBSD 9.0sparcipv6toolkit-1.4.1.tgz
NetBSD 9.0sparcipv6toolkit-1.4.1.tgz
NetBSD 9.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 9.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 9.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 9.0x86_64ipv6toolkit-1.4.1.tgz
NetBSD 9.0x86_64ipv6toolkit-1.4.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.