pkgtools/gimme - The NetBSD Packages Collection

Script to make binary packages in a chroot

Sometimes, there's a need to just build a package without any of the
installed pre-requisites being used. Or building a one-off package
which can then be used elsewhere.

This package helps to produce other binary packages, using pkg_comp to
build them in a chroot.  The chroot is populated either by cloning the
current operating system, or by using pre-existing binary sets.  As an
example:

	# gimme -c vip

will clone the current operating system on this host, and use it to
make a chroot in which the sysutils/vip package will be built.

Similarly, to build packages and all their pre-requisites afresh,
something like

	# gimme -c mercurial git-base

would be used.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

pkgtools/pkg_comp1

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgimme-20170213.tgz
NetBSD 8.0earmv7hfgimme-20170213.tgz
NetBSD 8.0earmv7hfgimme-20170213.tgz
NetBSD 8.0i386gimme-20170213.tgz
NetBSD 8.0i386gimme-20170213.tgz
NetBSD 8.0powerpcgimme-20170213.tgz
NetBSD 8.0powerpcgimme-20170213.tgz
NetBSD 8.0powerpcgimme-20170213.tgz
NetBSD 8.0powerpcgimme-20170213.tgz
NetBSD 8.0x86_64gimme-20170213.tgz
NetBSD 8.0x86_64gimme-20170213.tgz
NetBSD 9.0aarch64gimme-20170213.tgz
NetBSD 9.0aarch64gimme-20170213.tgz
NetBSD 9.0aarch64gimme-20170213.tgz
NetBSD 9.0alphagimme-20170213.tgz
NetBSD 9.0alphagimme-20170213.tgz
NetBSD 9.0alphagimme-20170213.tgz
NetBSD 9.0earmv6hfgimme-20170213.tgz
NetBSD 9.0earmv6hfgimme-20170213.tgz
NetBSD 9.0earmv6hfgimme-20170213.tgz
NetBSD 9.0earmv7hfgimme-20170213.tgz
NetBSD 9.0earmv7hfgimme-20170213.tgz
NetBSD 9.0earmv7hfgimme-20170213.tgz
NetBSD 9.0earmv7hfgimme-20170213.tgz
NetBSD 9.0i386gimme-20170213.tgz
NetBSD 9.0i386gimme-20170213.tgz
NetBSD 9.0i386gimme-20170213.tgz
NetBSD 9.0mips64ebgimme-20170213.tgz
NetBSD 9.0mips64ebgimme-20170213.tgz
NetBSD 9.0mips64ebgimme-20170213.tgz
NetBSD 9.0mips64ebgimme-20170213.tgz
NetBSD 9.0mips64ebgimme-20170213.tgz
NetBSD 9.0powerpcgimme-20170213.tgz
NetBSD 9.0powerpcgimme-20170213.tgz
NetBSD 9.0powerpcgimme-20170213.tgz
NetBSD 9.0powerpcgimme-20170213.tgz
NetBSD 9.0sparc64gimme-20170213.tgz
NetBSD 9.0sparc64gimme-20170213.tgz
NetBSD 9.0sparc64gimme-20170213.tgz
NetBSD 9.0sparcgimme-20170213.tgz
NetBSD 9.0sparcgimme-20170213.tgz
NetBSD 9.0sparcgimme-20170213.tgz
NetBSD 9.0x86_64gimme-20170213.tgz
NetBSD 9.0x86_64gimme-20170213.tgz
NetBSD 9.0x86_64gimme-20170213.tgz
NetBSD 9.0x86_64gimme-20170213.tgz
NetBSD 9.0x86_64gimme-20170213.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.