news/nntpcache - The NetBSD Packages Collection

NNTP multi-server caching daemon

NNTPCache is Squid for news (plus lots more).

NNTPCache can take reader loads off major news-servers. Besides its
super efficient execution, a single or multi-layer concentric ring of
NNTPCaches can be arranged about one or more central news-servers on a
DNS round-robin basis. Such a wall of NNTPCaches provides drop-in
scalability, redundancy, authentication & security for even the
largest news-server heart. NNTPCache can transparently stitch multiple
split news-servers (e.g, one news-server carrying alt.binaries.*,
another carrying alt.*, and another carrying everything else) back
together, allowing news-server administrators to spread their news
feeds over multiple machines, or to out-source selected components.

NNTPCache minimizes the effects of news-server down time, by continuing
to provide cached news-data in the face of news-server fall-over.

NNTPCache natively supports a variety of AUTHINFO methods, including
/etc/passwd, generic unix pipes, LDAP and radius.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfnntpcache-3.0.2nb18.tgz
NetBSD 8.0earmv7hfnntpcache-3.0.2nb17.tgz
NetBSD 8.0earmv7hfnntpcache-3.0.2nb18.tgz
NetBSD 8.0i386nntpcache-3.0.2nb17.tgz
NetBSD 8.0i386nntpcache-3.0.2nb18.tgz
NetBSD 8.0powerpcnntpcache-3.0.2nb17.tgz
NetBSD 8.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 8.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 8.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 8.0x86_64nntpcache-3.0.2nb17.tgz
NetBSD 8.0x86_64nntpcache-3.0.2nb18.tgz
NetBSD 9.0aarch64nntpcache-3.0.2nb18.tgz
NetBSD 9.0aarch64nntpcache-3.0.2nb17.tgz
NetBSD 9.0aarch64nntpcache-3.0.2nb18.tgz
NetBSD 9.0alphanntpcache-3.0.2nb18.tgz
NetBSD 9.0alphanntpcache-3.0.2nb17.tgz
NetBSD 9.0alphanntpcache-3.0.2nb18.tgz
NetBSD 9.0earmnntpcache-3.0.2nb17.tgz
NetBSD 9.0earmnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmv6hfnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmv6hfnntpcache-3.0.2nb17.tgz
NetBSD 9.0earmv6hfnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmv7hfnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmv7hfnntpcache-3.0.2nb17.tgz
NetBSD 9.0earmv7hfnntpcache-3.0.2nb18.tgz
NetBSD 9.0earmv7hfnntpcache-3.0.2nb18.tgz
NetBSD 9.0i386nntpcache-3.0.2nb17.tgz
NetBSD 9.0i386nntpcache-3.0.2nb18.tgz
NetBSD 9.0i386nntpcache-3.0.2nb18.tgz
NetBSD 9.0mips64ebnntpcache-3.0.2nb18.tgz
NetBSD 9.0mips64ebnntpcache-3.0.2nb17.tgz
NetBSD 9.0mips64ebnntpcache-3.0.2nb17.tgz
NetBSD 9.0mips64ebnntpcache-3.0.2nb17.tgz
NetBSD 9.0mips64ebnntpcache-3.0.2nb18.tgz
NetBSD 9.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 9.0powerpcnntpcache-3.0.2nb17.tgz
NetBSD 9.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 9.0powerpcnntpcache-3.0.2nb18.tgz
NetBSD 9.0sparc64nntpcache-3.0.2nb18.tgz
NetBSD 9.0sparc64nntpcache-3.0.2nb17.tgz
NetBSD 9.0sparc64nntpcache-3.0.2nb18.tgz
NetBSD 9.0sparcnntpcache-3.0.2nb18.tgz
NetBSD 9.0sparcnntpcache-3.0.2nb17.tgz
NetBSD 9.0sparcnntpcache-3.0.2nb17.tgz
NetBSD 9.0sparcnntpcache-3.0.2nb18.tgz
NetBSD 9.0x86_64nntpcache-3.0.2nb18.tgz
NetBSD 9.0x86_64nntpcache-3.0.2nb17.tgz
NetBSD 9.0x86_64nntpcache-3.0.2nb18.tgz
NetBSD 9.0x86_64nntpcache-3.0.2nb18.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

nntpcache-pgp
Enable pgp signed nocem support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.