news/inn - The NetBSD Packages Collection

The public release of InterNet News (INN)

This is the public release of InterNet News (INN). This work is
sponsored by the Internet Software Consortium.

InterNetNews is a complete Usenet system.  The cornerstone of the
package is innd, an NNTP server that multiplexes all I/O. Newsreading
is handled by a separate server, nnrpd, that is spawned for each
client.  Both innd and nnrpd have some slight variances from the
NNTP protocol.

You can set the environment variable INN_SPOOL to whatever you like
to change the default spool directory when building this pkg.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

mail/p5-MIME-tools graphics/p5-GD security/gnupg lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfinn-2.6.3nb1.tgz
NetBSD 8.0earmv7hfinn-2.6.3.tgz
NetBSD 8.0earmv7hfinn-2.6.3nb1.tgz
NetBSD 8.0i386inn-2.6.3.tgz
NetBSD 8.0i386inn-2.6.3nb1.tgz
NetBSD 8.0powerpcinn-2.6.3.tgz
NetBSD 8.0powerpcinn-2.6.3nb1.tgz
NetBSD 8.0powerpcinn-2.6.3nb1.tgz
NetBSD 8.0powerpcinn-2.6.3nb1.tgz
NetBSD 8.0x86_64inn-2.6.3.tgz
NetBSD 8.0x86_64inn-2.6.3nb1.tgz
NetBSD 9.0aarch64inn-2.6.3nb1.tgz
NetBSD 9.0aarch64inn-2.6.3.tgz
NetBSD 9.0aarch64inn-2.6.3nb1.tgz
NetBSD 9.0alphainn-2.6.3nb1.tgz
NetBSD 9.0alphainn-2.6.3.tgz
NetBSD 9.0alphainn-2.6.3nb1.tgz
NetBSD 9.0earminn-2.6.3.tgz
NetBSD 9.0earminn-2.6.3nb1.tgz
NetBSD 9.0earminn-2.6.3nb1.tgz
NetBSD 9.0earmv6hfinn-2.6.3nb1.tgz
NetBSD 9.0earmv6hfinn-2.6.3.tgz
NetBSD 9.0earmv6hfinn-2.6.3nb1.tgz
NetBSD 9.0earmv7hfinn-2.6.3nb1.tgz
NetBSD 9.0earmv7hfinn-2.6.3.tgz
NetBSD 9.0earmv7hfinn-2.6.3nb1.tgz
NetBSD 9.0earmv7hfinn-2.6.3nb1.tgz
NetBSD 9.0i386inn-2.6.3.tgz
NetBSD 9.0i386inn-2.6.3nb1.tgz
NetBSD 9.0i386inn-2.6.3nb1.tgz
NetBSD 9.0mips64ebinn-2.6.3nb1.tgz
NetBSD 9.0mips64ebinn-2.6.1nb5.tgz
NetBSD 9.0mips64ebinn-2.6.1nb6.tgz
NetBSD 9.0mips64ebinn-2.6.3.tgz
NetBSD 9.0mips64ebinn-2.6.3nb1.tgz
NetBSD 9.0powerpcinn-2.6.3nb1.tgz
NetBSD 9.0powerpcinn-2.6.3.tgz
NetBSD 9.0powerpcinn-2.6.3nb1.tgz
NetBSD 9.0powerpcinn-2.6.3nb1.tgz
NetBSD 9.0sh3elinn-2.6.3.tgz
NetBSD 9.0sparc64inn-2.6.3nb1.tgz
NetBSD 9.0sparc64inn-2.6.3.tgz
NetBSD 9.0sparc64inn-2.6.3nb1.tgz
NetBSD 9.0sparcinn-2.6.3nb1.tgz
NetBSD 9.0sparcinn-2.6.1nb5.tgz
NetBSD 9.0sparcinn-2.6.1nb6.tgz
NetBSD 9.0sparcinn-2.6.3.tgz
NetBSD 9.0sparcinn-2.6.3nb1.tgz
NetBSD 9.0x86_64inn-2.6.3nb1.tgz
NetBSD 9.0x86_64inn-2.6.3nb1.tgz
NetBSD 9.0x86_64inn-2.6.3.tgz
NetBSD 9.0x86_64inn-2.6.3nb1.tgz
NetBSD 9.0x86_64inn-2.6.3nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnupg2
Use GNU Privacy Guard (GnuPG) Version 2.0
kerberos
Enable Kerberos support.
perl
Enable Perl support.
python
Enable Python support.
uucp
Enable support for uucp.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.