net/libktorrent - The NetBSD Packages Collection

BitTorrent protocol implementation

KTorrent has sbeen split into the application ktorrent and the library
libktorrent.  Libktorrent contains all the torrent downloading code and
ktorrent contains all application code and plugins.  The goal is to make
libktorrent an independent library which can be used by other
applications.

Build dependencies

pkgtools/x11-links devel/boost-headers x11/xorgproto x11/xcb-proto x11/xcb-proto devel/extra-cmake-modules devel/cmake devel/glib2-tools pkgtools/mktools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

security/gnupg2 devel/gmp devel/kio x11/qt5-qtbase security/qca2-qt5 devel/gmp devel/kio x11/qt5-qtbase security/qca2-qt5

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64libktorrent-1.3.1nb43.tgz
NetBSD 10.0aarch64libktorrent-23.04.3.tgz
NetBSD 10.0earmv6hflibktorrent-1.3.1nb43.tgz
NetBSD 10.0earmv6hflibktorrent-23.04.3.tgz
NetBSD 10.0earmv7hflibktorrent-23.04.3.tgz
NetBSD 10.0i386libktorrent-23.04.3nb3.tgz
NetBSD 10.0i386libktorrent-23.04.3.tgz
NetBSD 10.0powerpclibktorrent-23.04.3.tgz
NetBSD 10.0x86_64libktorrent-23.04.3nb3.tgz
NetBSD 10.0_BETAx86_64libktorrent-23.04.3.tgz
NetBSD 9.0aarch64libktorrent-1.3.1nb43.tgz
NetBSD 9.0aarch64libktorrent-23.04.3.tgz
NetBSD 9.0alphalibktorrent-1.3.1nb41.tgz
NetBSD 9.0earmv6hflibktorrent-1.3.1nb43.tgz
NetBSD 9.0earmv7hflibktorrent-1.3.1nb43.tgz
NetBSD 9.0earmv7hflibktorrent-23.04.3.tgz
NetBSD 9.0i386libktorrent-23.04.3nb3.tgz
NetBSD 9.0powerpclibktorrent-23.04.3.tgz
NetBSD 9.0powerpclibktorrent-1.3.1nb41.tgz
NetBSD 9.0powerpclibktorrent-1.3.1nb43.tgz
NetBSD 9.0sparc64libktorrent-1.3.1nb41.tgz
NetBSD 9.0x86_64libktorrent-23.04.3nb3.tgz
NetBSD 9.3x86_64libktorrent-1.3.1nb43.tgz
NetBSD 9.3x86_64libktorrent-23.04.3nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.