multimedia/gst-plugins1-ugly - The NetBSD Packages Collection

Open source multimedia framework - ugly plugins

GStreamer Ugly Plug-ins is a set of plug-ins that have good quality
and correct functionality, but distributing them might pose problems.
The license on either the plug-ins or the supporting libraries
might not be how we'd like. The code might be widely known to
present patent problems.

Build dependencies

pkgtools/cwrappers devel/meson lang/python39 devel/glib2-tools devel/pkgconf

Runtime dependencies

multimedia/gst-plugins1-base multimedia/gstreamer1 multimedia/gst-plugins1-base multimedia/gstreamer1

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0i386gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0i386gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 8.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0aarch64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0aarch64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0aarch64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0aarch64gst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0alphagst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0alphagst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0alphagst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0alphagst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0earmgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv6hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv6hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv6hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv6hfgst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv7hfgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0earmv7hfgst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0i386gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0i386gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0i386gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0m68kgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0m68kgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0mips64ebgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0mips64ebgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0mips64ebgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0mips64ebgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0mips64ebgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0powerpcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sh3elgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sh3elgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sh3elgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sh3elgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparc64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparc64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparc64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparc64gst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0sparcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0sparcgst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.18.5nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.16.2nb1.tgz
NetBSD 9.0x86_64gst-plugins1-ugly-1.18.5nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.