multimedia/avidemux - The NetBSD Packages Collection

Graphical video editing program

Avidemux is a graphical tool to edit video.  It can open several file
formats, and various audio and video codecs.  Video can be edited,
cut, appended, filtered (resize/crop/denoise), and re-encoded. Output
file formats include Avi, MPEG1/2, MPEG2PS, OGM, and raw stripped audio
or video.

Build dependencies

devel/yasm pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/cmake devel/gmake devel/pkgconf

Runtime dependencies

audio/pulseaudio audio/libvorbis audio/faac audio/faad2 audio/lame audio/liba52 audio/libsamplerate audio/libmad devel/SDL graphics/freetype2 graphics/freetype2 graphics/hicolor-icon-theme lang/spidermonkey multimedia/xvidcore multimedia/x264-devel sysutils/desktop-file-utils textproc/libxml2 x11/gtk2 x11/libXv audio/libvorbis audio/faac audio/lame audio/liba52 audio/libsamplerate audio/libmad devel/SDL graphics/hicolor-icon-theme lang/spidermonkey multimedia/xvidcore sysutils/desktop-file-utils textproc/libxml2 x11/gtk2

Binary packages

OSArchitectureVersion
NetBSD 8.0powerpcavidemux-2.5.4nb53.tgz
NetBSD 8.0powerpcavidemux-2.5.4nb55.tgz
NetBSD 8.0x86_64avidemux-2.5.4nb53.tgz
NetBSD 8.0x86_64avidemux-2.5.4nb54.tgz
NetBSD 9.0i386avidemux-2.5.4nb53.tgz
NetBSD 9.0i386avidemux-2.5.4nb55.tgz
NetBSD 9.0powerpcavidemux-2.5.4nb53.tgz
NetBSD 9.0powerpcavidemux-2.5.4nb55.tgz
NetBSD 9.0x86_64avidemux-2.5.4nb54.tgz
NetBSD 9.0x86_64avidemux-2.5.4nb55.tgz
NetBSD 9.0x86_64avidemux-2.5.4nb53.tgz
NetBSD 9.0x86_64avidemux-2.5.4nb54.tgz
NetBSD 9.0x86_64avidemux-2.5.4nb55.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

pulseaudio
Enable support for the PulseAudio sound server.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.