math/svmlin - The NetBSD Packages Collection

Fast Linear SVM Solvers for Supervised and Semi-supervised Learning

SVMlin  is software package for linear SVMs.  It is well-suited to
classification problems involving a large number of examples and features.
It is primarily written for sparse datasets.

SVMlin  can also utilize unlabeled data, in addition to labeled examples.
It currently implements two extensions of standard SVMs to incorporate
unlabeled examples.

SVMlin  implements the following algorithms:
  - Fully supervised [using only labeled examples]
    * Linear  Regularized Least Squares (RLS) Classification
    * Modified Finite Newton  Linear L2-SVMs
  - Semi-supervised [can use unlabeled data as well]
    * Linear Transductive L2-SVMs  with multiple switchings
    * Deterministic Annealing (DA) for Semi-supervised Linear L2-SVMs

Build dependencies

devel/mk-configure pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsvmlin-1.0.tgz
NetBSD 8.0earmv7hfsvmlin-1.0.tgz
NetBSD 8.0earmv7hfsvmlin-1.0.tgz
NetBSD 8.0i386svmlin-1.0.tgz
NetBSD 8.0i386svmlin-1.0.tgz
NetBSD 8.0powerpcsvmlin-1.0.tgz
NetBSD 8.0powerpcsvmlin-1.0.tgz
NetBSD 8.0powerpcsvmlin-1.0.tgz
NetBSD 8.0powerpcsvmlin-1.0.tgz
NetBSD 8.0x86_64svmlin-1.0.tgz
NetBSD 8.0x86_64svmlin-1.0.tgz
NetBSD 9.0aarch64svmlin-1.0.tgz
NetBSD 9.0aarch64svmlin-1.0.tgz
NetBSD 9.0aarch64svmlin-1.0.tgz
NetBSD 9.0alphasvmlin-1.0.tgz
NetBSD 9.0alphasvmlin-1.0.tgz
NetBSD 9.0alphasvmlin-1.0.tgz
NetBSD 9.0earmv6hfsvmlin-1.0.tgz
NetBSD 9.0earmv6hfsvmlin-1.0.tgz
NetBSD 9.0earmv6hfsvmlin-1.0.tgz
NetBSD 9.0earmv7hfsvmlin-1.0.tgz
NetBSD 9.0earmv7hfsvmlin-1.0.tgz
NetBSD 9.0earmv7hfsvmlin-1.0.tgz
NetBSD 9.0earmv7hfsvmlin-1.0.tgz
NetBSD 9.0i386svmlin-1.0.tgz
NetBSD 9.0i386svmlin-1.0.tgz
NetBSD 9.0i386svmlin-1.0.tgz
NetBSD 9.0mips64ebsvmlin-1.0.tgz
NetBSD 9.0mips64ebsvmlin-1.0.tgz
NetBSD 9.0mips64ebsvmlin-1.0.tgz
NetBSD 9.0mips64ebsvmlin-1.0.tgz
NetBSD 9.0mips64ebsvmlin-1.0.tgz
NetBSD 9.0powerpcsvmlin-1.0.tgz
NetBSD 9.0powerpcsvmlin-1.0.tgz
NetBSD 9.0powerpcsvmlin-1.0.tgz
NetBSD 9.0powerpcsvmlin-1.0.tgz
NetBSD 9.0sparc64svmlin-1.0.tgz
NetBSD 9.0sparc64svmlin-1.0.tgz
NetBSD 9.0sparc64svmlin-1.0.tgz
NetBSD 9.0sparcsvmlin-1.0.tgz
NetBSD 9.0sparcsvmlin-1.0.tgz
NetBSD 9.0sparcsvmlin-1.0.tgz
NetBSD 9.0sparcsvmlin-1.0.tgz
NetBSD 9.0x86_64svmlin-1.0.tgz
NetBSD 9.0x86_64svmlin-1.0.tgz
NetBSD 9.0x86_64svmlin-1.0.tgz
NetBSD 9.0x86_64svmlin-1.0.tgz
NetBSD 9.0x86_64svmlin-1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.