math/superlu - The NetBSD Packages Collection

Library for solving large, sparse, nonsymmetric systems of linear equations

SuperLU contains a set of subroutines to solve a sparse linear system
A*X=B. It uses Gaussian elimination with partial pivoting (GEPP).  The
columns of A may be preordered before factorization; the preordering
for sparsity is completely separate from the factorization.

SuperLU is implemented in ANSI C, and must be compiled with standard
ANSI C compilers. It provides functionality for both real and complex
matrices, in both single and double precision.

Build dependencies

pkgtools/cwrappers devel/cmake

Runtime dependencies

math/lapack lang/gcc7 math/lapack lang/gcc7

Binary packages

OSArchitectureVersion
NetBSD 8.0i386superlu-5.2.1nb2.tgz
NetBSD 8.0i386superlu-5.2.1nb3.tgz
NetBSD 8.0powerpcsuperlu-5.2.1nb2.tgz
NetBSD 8.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 8.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 8.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 8.0x86_64superlu-5.2.1nb2.tgz
NetBSD 8.0x86_64superlu-5.2.1nb3.tgz
NetBSD 9.0aarch64superlu-5.2.1nb3.tgz
NetBSD 9.0aarch64superlu-5.2.1nb2.tgz
NetBSD 9.0aarch64superlu-5.2.1nb3.tgz
NetBSD 9.0alphasuperlu-5.2.1nb3.tgz
NetBSD 9.0alphasuperlu-5.2.1nb2.tgz
NetBSD 9.0alphasuperlu-5.2.1nb3.tgz
NetBSD 9.0i386superlu-5.2.1nb2.tgz
NetBSD 9.0i386superlu-5.2.1nb3.tgz
NetBSD 9.0i386superlu-5.2.1nb3.tgz
NetBSD 9.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 9.0powerpcsuperlu-5.2.1nb2.tgz
NetBSD 9.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 9.0powerpcsuperlu-5.2.1nb3.tgz
NetBSD 9.0sparc64superlu-5.2.1nb3.tgz
NetBSD 9.0sparc64superlu-5.2.1nb2.tgz
NetBSD 9.0sparc64superlu-5.2.1nb3.tgz
NetBSD 9.0x86_64superlu-5.2.1nb3.tgz
NetBSD 9.0x86_64superlu-5.2.1nb3.tgz
NetBSD 9.0x86_64superlu-5.2.1nb2.tgz
NetBSD 9.0x86_64superlu-5.2.1nb3.tgz
NetBSD 9.0x86_64superlu-5.2.1nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.