math/p5-Number-WithError - The NetBSD Packages Collection

Numbers with error propagation and scientific rounding

This perl class is a container class for numbers with a number of
associated symmetric and asymmetric errors. It overloads practically
all common arithmetic operations and trigonometric functions to
propagate the errors. It can do proper scientific rounding.

Build dependencies

devel/p5-Module-Install pkgtools/cwrappers

Runtime dependencies

devel/p5-Params-Util devel/p5-prefork lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Number-WithError-1.01nb4.tgz
NetBSD 8.0earmv7hfp5-Number-WithError-1.01nb3.tgz
NetBSD 8.0earmv7hfp5-Number-WithError-1.01nb4.tgz
NetBSD 8.0i386p5-Number-WithError-1.01nb3.tgz
NetBSD 8.0i386p5-Number-WithError-1.01nb4.tgz
NetBSD 8.0powerpcp5-Number-WithError-1.01nb3.tgz
NetBSD 8.0powerpcp5-Number-WithError-1.01nb4.tgz
NetBSD 8.0powerpcp5-Number-WithError-1.01nb4.tgz
NetBSD 8.0powerpcp5-Number-WithError-1.01nb4.tgz
NetBSD 8.0x86_64p5-Number-WithError-1.01nb3.tgz
NetBSD 8.0x86_64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0aarch64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0aarch64p5-Number-WithError-1.01nb3.tgz
NetBSD 9.0aarch64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0earmp5-Number-WithError-1.01nb3.tgz
NetBSD 9.0earmv6hfp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0earmv6hfp5-Number-WithError-1.01nb3.tgz
NetBSD 9.0earmv6hfp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0earmv7hfp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0earmv7hfp5-Number-WithError-1.01nb3.tgz
NetBSD 9.0earmv7hfp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0earmv7hfp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0i386p5-Number-WithError-1.01nb3.tgz
NetBSD 9.0i386p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0i386p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0mips64ebp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0mips64ebp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0powerpcp5-Number-WithError-1.01nb3.tgz
NetBSD 9.0powerpcp5-Number-WithError-1.01nb4.tgz
NetBSD 9.0sparc64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0sparc64p5-Number-WithError-1.01nb3.tgz
NetBSD 9.0sparc64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0x86_64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0x86_64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0x86_64p5-Number-WithError-1.01nb3.tgz
NetBSD 9.0x86_64p5-Number-WithError-1.01nb4.tgz
NetBSD 9.0x86_64p5-Number-WithError-1.01nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.