math/gp-fplsa - The NetBSD Packages Collection

GAP interface to FPLSA

This package is a GAP interface to a C program called fplsa for
dealing with finitely presented Lie super-algebras.

When K is a finitely-presented Lie algebra, the GAP Operation
`IsomorphismSCTableAlgebra' can be used to make the structure of K
explicit, in the form of an isomorphic algebra given by structure
constants, which is much more amenable to further computations.

This GAP package installs an alternative method for this Operation,
which calls fplsa to do the hard part of the computation. This speeds
up the calculation and permits larger problems to be attempted. The
external program has much additional functionality which is not used
by the present version of the package.

Build dependencies

pkgtools/cwrappers archivers/unzoo

Runtime dependencies

math/gap

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 8.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 8.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 8.0i386gp-fplsa-1.0nb2.tgz
NetBSD 8.0i386gp-fplsa-1.0nb2.tgz
NetBSD 8.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 8.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 8.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 8.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 8.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 8.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 9.0aarch64gp-fplsa-1.0nb2.tgz
NetBSD 9.0aarch64gp-fplsa-1.0nb2.tgz
NetBSD 9.0aarch64gp-fplsa-1.0nb2.tgz
NetBSD 9.0alphagp-fplsa-1.0nb2.tgz
NetBSD 9.0alphagp-fplsa-1.0nb2.tgz
NetBSD 9.0alphagp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv6hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv6hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv6hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0earmv7hfgp-fplsa-1.0nb2.tgz
NetBSD 9.0i386gp-fplsa-1.0nb2.tgz
NetBSD 9.0i386gp-fplsa-1.0nb2.tgz
NetBSD 9.0i386gp-fplsa-1.0nb2.tgz
NetBSD 9.0mips64ebgp-fplsa-1.0nb2.tgz
NetBSD 9.0mips64ebgp-fplsa-1.0nb2.tgz
NetBSD 9.0mips64ebgp-fplsa-1.0nb2.tgz
NetBSD 9.0mips64ebgp-fplsa-1.0nb2.tgz
NetBSD 9.0mips64ebgp-fplsa-1.0nb2.tgz
NetBSD 9.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 9.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 9.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 9.0powerpcgp-fplsa-1.0nb2.tgz
NetBSD 9.0sparc64gp-fplsa-1.0nb2.tgz
NetBSD 9.0sparc64gp-fplsa-1.0nb2.tgz
NetBSD 9.0sparc64gp-fplsa-1.0nb2.tgz
NetBSD 9.0sparcgp-fplsa-1.0nb2.tgz
NetBSD 9.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 9.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 9.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 9.0x86_64gp-fplsa-1.0nb2.tgz
NetBSD 9.0x86_64gp-fplsa-1.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.