math/fftw2 - The NetBSD Packages Collection

Collection of fast C routines to compute DFTs

This is FFTW version 2.  FFTW is a collection of fast C routines to
compute the Discrete Fourier Transform in one or more dimensions.

Uptream says (but apparently there was a relaase in 2003):
If you are still using FFTW 2.x, please note that FFTW 2.x was last
updated in 1999 and it is obsolete. Please upgrade to FFTW 3.x. The
API of FFTW 3.x is incompatible with that of FFTW 2.x, for reasons of
performance and generality (see the FAQ or the manual).

Build dependencies

devel/libtool-fortran pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

lang/gcc7 lang/gcc7

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 8.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 8.0i386fftw2-2.1.5nb3.tgz
NetBSD 8.0i386fftw2-2.1.5nb3.tgz
NetBSD 8.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 8.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 8.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 8.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 8.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 8.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 9.0aarch64fftw2-2.1.5nb3.tgz
NetBSD 9.0aarch64fftw2-2.1.5nb3.tgz
NetBSD 9.0aarch64fftw2-2.1.5nb3.tgz
NetBSD 9.0alphafftw2-2.1.5nb3.tgz
NetBSD 9.0alphafftw2-2.1.5nb3.tgz
NetBSD 9.0alphafftw2-2.1.5nb3.tgz
NetBSD 9.0earmfftw2-2.1.5nb3.tgz
NetBSD 9.0earmfftw2-2.1.5nb3.tgz
NetBSD 9.0earmfftw2-2.1.5nb3.tgz
NetBSD 9.0earmv6hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv6hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv6hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 9.0earmv7hffftw2-2.1.5nb3.tgz
NetBSD 9.0i386fftw2-2.1.5nb3.tgz
NetBSD 9.0i386fftw2-2.1.5nb3.tgz
NetBSD 9.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 9.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 9.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 9.0powerpcfftw2-2.1.5nb3.tgz
NetBSD 9.0sparc64fftw2-2.1.5nb3.tgz
NetBSD 9.0sparc64fftw2-2.1.5nb3.tgz
NetBSD 9.0sparc64fftw2-2.1.5nb3.tgz
NetBSD 9.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 9.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 9.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 9.0x86_64fftw2-2.1.5nb3.tgz
NetBSD 9.0x86_64fftw2-2.1.5nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.