math/fftw - The NetBSD Packages Collection

Fast C routines to compute DFTs (single and double precision)

FFTW is a C subroutine library for computing the discrete Fourier transform
(DFT) in one or more dimensions, of arbitrary input size, and of both real
and complex data (as well as of even/odd data, i.e. the discrete cosine/sine
transforms or DCT/DST).

This package contains the single and double precision floating point FFTW
libraries.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffftw-3.3.9nb8.tgz
NetBSD 8.0earmv7hffftw-3.3.9nb3.tgz
NetBSD 8.0earmv7hffftw-3.3.9nb8.tgz
NetBSD 8.0i386fftw-3.3.9nb3.tgz
NetBSD 8.0i386fftw-3.3.9nb8.tgz
NetBSD 8.0powerpcfftw-3.3.9nb3.tgz
NetBSD 8.0powerpcfftw-3.3.9nb8.tgz
NetBSD 8.0powerpcfftw-3.3.9nb8.tgz
NetBSD 8.0powerpcfftw-3.3.9nb8.tgz
NetBSD 8.0x86_64fftw-3.3.9nb3.tgz
NetBSD 8.0x86_64fftw-3.3.9nb8.tgz
NetBSD 9.0aarch64fftw-3.3.9nb8.tgz
NetBSD 9.0aarch64fftw-3.3.9nb3.tgz
NetBSD 9.0aarch64fftw-3.3.9nb8.tgz
NetBSD 9.0alphafftw-3.3.9nb8.tgz
NetBSD 9.0alphafftw-3.3.9nb3.tgz
NetBSD 9.0alphafftw-3.3.9nb8.tgz
NetBSD 9.0earmfftw-3.3.9nb3.tgz
NetBSD 9.0earmfftw-3.3.9nb8.tgz
NetBSD 9.0earmfftw-3.3.9nb8.tgz
NetBSD 9.0earmv6hffftw-3.3.9nb8.tgz
NetBSD 9.0earmv6hffftw-3.3.9nb3.tgz
NetBSD 9.0earmv6hffftw-3.3.9nb8.tgz
NetBSD 9.0earmv7hffftw-3.3.9nb8.tgz
NetBSD 9.0earmv7hffftw-3.3.9nb3.tgz
NetBSD 9.0earmv7hffftw-3.3.9nb8.tgz
NetBSD 9.0earmv7hffftw-3.3.9nb8.tgz
NetBSD 9.0i386fftw-3.3.9nb3.tgz
NetBSD 9.0i386fftw-3.3.9nb8.tgz
NetBSD 9.0i386fftw-3.3.9nb8.tgz
NetBSD 9.0m68kfftw-3.3.8nb3.tgz
NetBSD 9.0m68kfftw-3.3.9nb3.tgz
NetBSD 9.0m68kfftw-3.3.9nb8.tgz
NetBSD 9.0m68kfftw-3.3.9nb8.tgz
NetBSD 9.0mips64ebfftw-3.3.9nb8.tgz
NetBSD 9.0mips64ebfftw-3.3.8nb3.tgz
NetBSD 9.0mips64ebfftw-3.3.8nb3.tgz
NetBSD 9.0mips64ebfftw-3.3.9nb3.tgz
NetBSD 9.0mips64ebfftw-3.3.9nb8.tgz
NetBSD 9.0mipselfftw-3.3.9nb8.tgz
NetBSD 9.0mipselfftw-3.3.8nb3.tgz
NetBSD 9.0mipselfftw-3.3.9nb3.tgz
NetBSD 9.0mipselfftw-3.3.9nb8.tgz
NetBSD 9.0powerpcfftw-3.3.9nb8.tgz
NetBSD 9.0powerpcfftw-3.3.9nb3.tgz
NetBSD 9.0powerpcfftw-3.3.9nb8.tgz
NetBSD 9.0powerpcfftw-3.3.9nb8.tgz
NetBSD 9.0sh3elfftw-3.3.9nb8.tgz
NetBSD 9.0sh3elfftw-3.3.8nb3.tgz
NetBSD 9.0sh3elfftw-3.3.8nb3.tgz
NetBSD 9.0sh3elfftw-3.3.9nb3.tgz
NetBSD 9.0sh3elfftw-3.3.9nb8.tgz
NetBSD 9.0sparc64fftw-3.3.9nb8.tgz
NetBSD 9.0sparc64fftw-3.3.9nb3.tgz
NetBSD 9.0sparc64fftw-3.3.9nb8.tgz
NetBSD 9.0sparcfftw-3.3.9nb8.tgz
NetBSD 9.0sparcfftw-3.3.8nb3.tgz
NetBSD 9.0sparcfftw-3.3.8nb3.tgz
NetBSD 9.0sparcfftw-3.3.9nb3.tgz
NetBSD 9.0sparcfftw-3.3.9nb8.tgz
NetBSD 9.0vaxfftw-3.3.9nb3.tgz
NetBSD 9.0vaxfftw-3.3.8nb3.tgz
NetBSD 9.0vaxfftw-3.3.9nb8.tgz
NetBSD 9.0vaxfftw-3.3.9nb8.tgz
NetBSD 9.0x86_64fftw-3.3.9nb8.tgz
NetBSD 9.0x86_64fftw-3.3.9nb8.tgz
NetBSD 9.0x86_64fftw-3.3.9nb3.tgz
NetBSD 9.0x86_64fftw-3.3.9nb8.tgz
NetBSD 9.0x86_64fftw-3.3.9nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

avx
Enable use of x86 Advanced Vector Extensions.
fftw-fortran
Enable Fortran support.
mpi
Enable use of the Message Passing Interface library.
openmp
Enable OpenMP multithreading.
simd
Enable use of SIMD vector instructions.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.