math/congen - The NetBSD Packages Collection

Constants generator for tidal constituents

congen is a C++ library for generating the speeds, equilibrium arguments,
and node factors of Darwin-style tidal constituents more or less as defined
in SP 98:

  Manual of Harmonic Analysis and Prediction of Tides.  Special Publication
  No. 98, Revised (1940) Edition (reprinted 1958 with corrections;
  reprinted again 1994).  United States Government Printing Office, 1994.

Additionally, libcongen provides limited support for approximating
Doodson-style tidal constituents within the infrastructure of the former.
The Doodson approach is discussed in the following publication:

  Foreman, M.G.G., 1977.  Manual for Tidal Heights Analysis and Prediction.
  Pacific Marine Science Report 77-10, Institute of Ocean Sciences,
  Patricia Bay, Sidney, B.C. (2004 revision).

The Congen header file is intended to be self-documenting with regards to use
of the interface, assuming that one has access to SP 98 and a general
understanding of the subject matter.

Build dependencies

pkgtools/cwrappers devel/libtool-base shells/bash devel/gmake textproc/gsed

Runtime dependencies

databases/libtcd lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcongen-1.7nb1.tgz
NetBSD 8.0earmv7hfcongen-1.7.tgz
NetBSD 8.0earmv7hfcongen-1.7.tgz
NetBSD 8.0i386congen-1.7.tgz
NetBSD 8.0i386congen-1.7.tgz
NetBSD 8.0powerpccongen-1.7.tgz
NetBSD 8.0powerpccongen-1.7.tgz
NetBSD 8.0powerpccongen-1.7.tgz
NetBSD 8.0powerpccongen-1.7nb1.tgz
NetBSD 8.0x86_64congen-1.7.tgz
NetBSD 8.0x86_64congen-1.7.tgz
NetBSD 9.0aarch64congen-1.7nb1.tgz
NetBSD 9.0aarch64congen-1.7.tgz
NetBSD 9.0aarch64congen-1.7.tgz
NetBSD 9.0alphacongen-1.7nb1.tgz
NetBSD 9.0alphacongen-1.7.tgz
NetBSD 9.0alphacongen-1.7.tgz
NetBSD 9.0earmcongen-1.7.tgz
NetBSD 9.0earmcongen-1.7.tgz
NetBSD 9.0earmv6hfcongen-1.7nb1.tgz
NetBSD 9.0earmv6hfcongen-1.7.tgz
NetBSD 9.0earmv6hfcongen-1.7.tgz
NetBSD 9.0earmv7hfcongen-1.7nb1.tgz
NetBSD 9.0earmv7hfcongen-1.7.tgz
NetBSD 9.0earmv7hfcongen-1.7.tgz
NetBSD 9.0earmv7hfcongen-1.7nb1.tgz
NetBSD 9.0i386congen-1.7.tgz
NetBSD 9.0i386congen-1.7.tgz
NetBSD 9.0i386congen-1.7nb1.tgz
NetBSD 9.0mips64ebcongen-1.7.tgz
NetBSD 9.0mips64ebcongen-1.7.tgz
NetBSD 9.0mips64ebcongen-1.7.tgz
NetBSD 9.0mips64ebcongen-1.7.tgz
NetBSD 9.0mips64ebcongen-1.7nb1.tgz
NetBSD 9.0powerpccongen-1.7.tgz
NetBSD 9.0powerpccongen-1.7.tgz
NetBSD 9.0powerpccongen-1.7.tgz
NetBSD 9.0powerpccongen-1.7.tgz
NetBSD 9.0powerpccongen-1.7nb1.tgz
NetBSD 9.0sh3elcongen-1.7.tgz
NetBSD 9.0sh3elcongen-1.7.tgz
NetBSD 9.0sh3elcongen-1.7.tgz
NetBSD 9.0sparc64congen-1.7.tgz
NetBSD 9.0sparc64congen-1.7.tgz
NetBSD 9.0sparc64congen-1.7nb1.tgz
NetBSD 9.0sparccongen-1.7.tgz
NetBSD 9.0sparccongen-1.7.tgz
NetBSD 9.0sparccongen-1.7.tgz
NetBSD 9.0sparccongen-1.7.tgz
NetBSD 9.0sparccongen-1.7nb1.tgz
NetBSD 9.0x86_64congen-1.7.tgz
NetBSD 9.0x86_64congen-1.7nb1.tgz
NetBSD 9.0x86_64congen-1.7.tgz
NetBSD 9.0x86_64congen-1.7.tgz
NetBSD 9.0x86_64congen-1.7nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.