mail/ezmlm-idx - The NetBSD Packages Collection

Version of ezmlm with enhancements by third parties

This is an addition and patch to ezmlm-0.53 [(c) Dan J. Bernstein].
Ezmlm-idx uses Dan's libraries and heavily relies on ezmlm-0.53
code.  ezmlm-idx does not function without ezmlm-0.53.

ezmlm-0.53 provides basic message distribution, subscriber address
handling, message archiving (single quoted message retrieval only),
and bounce handling. ezmlm-idx adds multi-message threaded archive
retrieval, digests, remote administration, message and subscription
moderation, subscriber-only restrictions, message trailer, subject
prefix, subscriber name storage, customizable setup, multi-language
and MIME support and more. In addition, improved bounce handling,
case-insensitive subscriber address storage, and support for
distributed lists (main + sublist transparent to the subscriber).
Ezmlm-idx can now be compiled with MySQL or Postgres support.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

mail/qmail

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfezmlm-idx-7.2.2nb16.tgz
NetBSD 8.0earmv7hfezmlm-idx-7.2.2nb14.tgz
NetBSD 8.0earmv7hfezmlm-idx-7.2.2nb15.tgz
NetBSD 8.0i386ezmlm-idx-7.2.2nb14.tgz
NetBSD 8.0i386ezmlm-idx-7.2.2nb15.tgz
NetBSD 8.0powerpcezmlm-idx-7.2.2nb14.tgz
NetBSD 8.0powerpcezmlm-idx-7.2.2nb15.tgz
NetBSD 8.0powerpcezmlm-idx-7.2.2nb15.tgz
NetBSD 8.0powerpcezmlm-idx-7.2.2nb16.tgz
NetBSD 8.0x86_64ezmlm-idx-7.2.2nb14.tgz
NetBSD 8.0x86_64ezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0aarch64ezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0aarch64ezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0aarch64ezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0alphaezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0alphaezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0alphaezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0earmv6hfezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0earmv6hfezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0earmv6hfezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0earmv7hfezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0earmv7hfezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0earmv7hfezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0earmv7hfezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0i386ezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0i386ezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0i386ezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0powerpcezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0powerpcezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0powerpcezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0powerpcezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0sparc64ezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0x86_64ezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0x86_64ezmlm-idx-7.2.2nb16.tgz
NetBSD 9.0x86_64ezmlm-idx-7.2.2nb14.tgz
NetBSD 9.0x86_64ezmlm-idx-7.2.2nb15.tgz
NetBSD 9.0x86_64ezmlm-idx-7.2.2nb16.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mysql
Enable MySQL support.
pgsql
Enable PostgreSQL support.
sqlite3
Enable SQLite3 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.